POJ-3278___抓奶牛——解题报告 BFS

原题链接:http://poj.org/problem?id=3278

Catch That Cow
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 104828   Accepted: 32790

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.


题目大意:

    FJ要抓奶牛,初始位置为N,可进行的操作为:N+1,N-1,N*2,每次操作耗时1min

解题思路:

    用BFS,对于单个元素的搜索,用queue即可

代码思路:

1、用queue来储存每个搜索的元素

2、head表示已搜索到的元素,next表示下一个搜索的元素并存储到queue中,同时进行判断

3、用vist布尔数组来记录已到达的位置

核心:在每次搜索时,已经访问到的点以后都不在访问,每条搜索路径不相交,即可获得做最短路径!


#include <iostream>
#include <queue>
#include <string.h>
using namespace std;
const int maxn = 100001;
int step[maxn];
bool vist[maxn];
int n,k;
queue <int> q;

int BFS(int n,int k)
{
	int head,next;
	q.push(n);
	step[n]=0;
	vist[n]=true;
	while(!q.empty())
	{
		head=q.front();
		q.pop();
		for(int i=0;i<3;i++)
		{
			if(i==0) next=head-1;
			else if(i==1) next=head+1;
			else next=head*2;	
		if(next<0||next>=maxn) continue;
		if(!vist[next])
		{
			q.push(next);
			step[next]=step[head]+1;
			vist[next]=true;
		}		
		if(next==k) return step[next];
		}
	}
}

int main()
{
	std::ios::sync_with_stdio(false);
	while(cin>>n>>k)
	{
		memset(step,0,sizeof(step));
		memset(vist,false,sizeof(vist));
		if(n>=k) cout<<n-k;
		else cout<<BFS(n,k)<<endl;	
	}
	return 0;
}


转载链接:http://blog.csdn.net/freezhanacmore/article/details/8168265

新手请多指教

猜你喜欢

转载自blog.csdn.net/scar_halo/article/details/79306870