HDU1003 最大子段和 线性dp

题目链接:

http://acm.hdu.edu.cn/showproblem.php?pid=1003

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 282195    Accepted Submission(s): 67034


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
 
Sample Output
Case 1: 14 1 4
 
Case 2: 7 1 6
 
Author
Ignatius.L
 
分析:
题目的数据很水啊
输入6 2 7 -9 5 4 3,答案应该是 12 1 6 的结果12 3 6竟然能过!!!!!!!
ac代码
#include<bits/stdc++.h>
using namespace std;
int main()
{
    int t;
    scanf("%d",&t);
    int T=1;
    while(T<=t)
    {
        int n;
        scanf("%d",&n);
        int a[n+1];
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
        }
        int dp[n+1],k1=1,k2=1;
        dp[1]=a[1];
        for(int i=2;i<=n;i++)
        {
            int x=dp[i-1];
            if(x<0)
            {
                x=0;
            }
            dp[i]=x+a[i];
        }
        int maxvalue=dp[1];
        for(int i=2;i<=n;i++)
        {
            if(maxvalue<dp[i])
            {
                maxvalue=dp[i];
                k2=i;
            }
        }
        for(int i=k2,x=0;x!=maxvalue;--i)
        {
            x=x+a[i];
            k1=i;
        }
        int s=0;
        for(int i=k2-1;i>=1;i--)
        {
            s=s+a[i];
            if(s==0)
                k1=i;
        }
        printf("Case %d:\n",T);
        printf("%d %d %d\n",maxvalue,k1,k2);
        if(T<t)
            printf("\n");
        T++;
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/yinbiao/p/8982377.html
今日推荐