PTA 列车调度 Java

PTA 列车调度 Java

火车站的列车调度铁轨的结构如下图所示。
在这里插入图片描述
两端分别是一条入口(Entrance)轨道和一条出口(Exit)轨道,它们之间有N条平行的轨道。每趟列车从入口可以选择任意一条轨道进入,最后从出口离开。在图中有9趟列车,在入口处按照{8,4,2,5,3,9,1,6,7}的顺序排队等待进入。如果要求它们必须按序号递减的顺序从出口离开,则至少需要多少条平行铁轨用于调度?
输入格式:
输入第一行给出一个整数N (2 ≤ N ≤105),下一行给出从1到N的整数序号的一个重排列。数字间以空格分隔。
输出格式:
在一行中输出可以将输入的列车按序号递减的顺序调离所需要的最少的铁轨条数。
输入样例:
9
8 4 2 5 3 9 1 6 7
输出样例:
4

今天想破头都没有想明白自己当时是怎么想的,然后发现我的算法其实是错误的,但是莫名通过了所有的测试用例…
错误举例
输入:
9
8 4 2 3 5 9 1 6 7
正确输出
5
实际输出
4
在这里插入图片描述
正确思路:需要使用一个数组来保存每条轨道上最小的列车编号,如果比所有的最小编号都大,则新增轨道,否则找到位置并更新轨道的最小编号。(查找可以使用二分查找,因为新增的轨道一定是比前面的列车编号都要大,所以整个数组本身就是有序的)

错误方法

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStream;
import java.io.InputStreamReader;
import java.util.StringTokenizer;

public class Main {
    public static void main(String[] args) throws IOException {
        Reader.init(System.in);
        int N = Reader.nextInt();
        int first = 0;
        int second = 0;
        int count = 0;
        for (int i = 0; i < N; i++) {
            int id = Reader.nextInt();
            if (id > first) {
                count++;
                second = first;
                first = id;
            } else if (id > second) {
                second = first;
                first = id;
            }
        }
        System.out.println(count);
    }

}

// Class for buffered reading int and double values *//*
class Reader {
    static BufferedReader reader;
    static StringTokenizer tokenizer;

    // ** call this method to initialize reader for InputStream *//*
    static void init(InputStream input) {
        reader = new BufferedReader(new InputStreamReader(input));
        tokenizer = new StringTokenizer("");
    }

    // ** get next word *//*
    static String next() throws IOException {
        while (!tokenizer.hasMoreTokens()) {
            // TODO add check for eof if necessary
            tokenizer = new StringTokenizer(reader.readLine());
        }
        return tokenizer.nextToken();
    }

    static String nextLine() throws IOException {
        return reader.readLine();
    }

    static int nextInt() throws IOException {
        return Integer.parseInt(next());
    }

    static char nextChar() throws IOException {
        return next().toCharArray()[0];
    }

    static float nextFloat() throws IOException {
        return Float.parseFloat(next());
    }
}

正确方法

import java.io.BufferedReader;
import java.io.BufferedWriter;
import java.io.IOException;
import java.io.InputStream;
import java.io.InputStreamReader;
import java.io.OutputStream;
import java.io.OutputStreamWriter;
import java.util.StringTokenizer;


public class Main {

	public static void main(String[] args) throws IOException {
		Reader.init(System.in);
		Writer.init(System.out);
		solve();
		Writer.close();
	}

	public static void solve() throws IOException {
		int n = Reader.nextInt();
		map = new int[n];
		int count = 0;
		map[count++] = Reader.nextInt();
		n--;
		while (n-- > 0) {
			int id = Reader.nextInt();
			if (map[count-1] < id) {
				map[count++] = id;
				continue;
			}
			int low = 0;
			int high = count - 1;
			while (low < high) {
				int mid = (low + high) >> 1;
				if (id < map[mid]) {
					high = mid;
				} else {
					low = mid + 1;
				}
			}
			map[low] = id;
		}
		Writer.print(count);
	}

	static int[] map;

}

// Class for buffered reading int and double values *//*
class Reader {
	static BufferedReader reader;
	static StringTokenizer tokenizer;

	// ** call this method to initialize reader for InputStream *//*
	static void init(InputStream input) {
		reader = new BufferedReader(new InputStreamReader(input));
		tokenizer = new StringTokenizer("");
	}

	// ** get next word *//*
	static String next() throws IOException {
		while (!tokenizer.hasMoreTokens()) {
			// TODO add check for eof if necessary
			tokenizer = new StringTokenizer(reader.readLine());
		}
		return tokenizer.nextToken();
	}

	static String nextLine() throws IOException {
		return reader.readLine();
	}

	static int nextInt() throws IOException {
		return Integer.parseInt(next());
	}

	static char nextChar() throws IOException {
		return next().toCharArray()[0];
	}

	static float nextFloat() throws IOException {
		return Float.parseFloat(next());
	}
}

class Writer {
	static BufferedWriter writer;

	static void init(OutputStream outputStream) {
		writer = new BufferedWriter(new OutputStreamWriter(outputStream));
	}

	static void print(Object object) throws IOException {
		writer.write(object.toString());
	}

	static void println(Object object) throws IOException {
		writer.write(object.toString());
		writer.write("\n");
	}

	static void close() throws IOException {
		// TODO Auto-generated method stub
		writer.close();
	}
}
发布了27 篇原创文章 · 获赞 2 · 访问量 1477

猜你喜欢

转载自blog.csdn.net/Samil_Hy/article/details/104196512