[HDU 1213 --- How Many Tables] disjoint-set

[HDU 1213 --- How Many Tables] disjoint-set

Topic Source: Click to enter [HDU 1213 - How Many Tables]

Description

Today is Ignatius’ birthday. He invites a lot of friends. Now it’s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input

2
5 3
1 2
2 3
4 5

5 1
2 5

Sample Output

2
4

Problem-solving ideas

And check catchment title, just a collection of the merger, the final traverse count how many sets you can have.

AC Code:

#include <iostream>
#include <algorithm>
using namespace std;
#define SIS std::ios::sync_with_stdio(false),cin.tie(0),cout.tie(0)
#define endl '\n'
const int MAXN = 1e3+5;
int pre[MAXN];

void init(int x)
{
    for(int i=1;i<=x;i++)
        pre[i]=i;
}

int _find(int x)
{
    if(x==pre[x]) return x;
    return pre[x]=_find(pre[x]);
}

void unite(int x,int y)
{
    x=_find(x);
    y=_find(y);
    if(x!=y) pre[x]=y;
}

int main()
{
    SIS;
    int T,n,m,a,b;
    cin >> T;
    while(T--)
    {
        cin >> n >> m;
        init(n);
        while(m--)
        {
            cin >> a >> b;
            unite(a,b);
        }
        int ans=0;
        for(int i=1;i<=n;i++)
            if(pre[i]==i) ans++;
        cout << ans << endl;
    }
    return 0;
}
Published 412 original articles · won praise 135 · views 40000 +

Guess you like

Origin blog.csdn.net/qq_41879343/article/details/104163021