Section 9.6 "algorithm Notes" - Special Data Structure (2) -> disjoint-set -> problem C: How Many Tables

Problem C: How Many Tables

Time limit: 1 Sec Memory Limit: 32 MB
submitted: 239 Resolution: 181
[ submit ] [ state ] [ Discussion Board ] [proposition man: External Import]

Title Description

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Entry

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Export

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample input

2
6 4
1 2
2 3
3 4
1 4

8 10
1 2
2 3
5 6
7 5
4 6
3 6
6 7
2 5
2 4
4 3

Sample Output

3
2

[ Submit ] [ state ]

#include<iostream>
using namespace std;

const int N=1005;
int father[N];

void init(int n){
	for(int i=1;i<=n;i++){
		father[i]=i;
	}
}
int findFather(int x){
	while(x!=father[x]){
		x=father[x];
	}
	return x;
}
void Union(int a,int b){
	int A=findFather(a);
	int B=findFather(b);
	if(A!=B){
		father[A]=B;
	}
}
int main(){
	int T;
	cin>>T;
	while(T--){
		int n,m;
		cin>>n>>m;
		init(n);
		if(n==0)
			break;
		
		for(int i=0;i<m;i++){
			int a,b;
			cin>>a>>b;
			Union(a,b);
		}
		int ans=0;
		for(int i=1;i<=n;i++){
			if(i==father[i])
				ans++;
		}
		cout<<ans<<endl;
	}
	return 0;
}

 

Published 52 original articles · won praise 7 · views 7527

Guess you like

Origin blog.csdn.net/Jason6620/article/details/104083789