[HDU 3038 --- How Many Answers Are Wrong] Weighted disjoint-set

[HDU 3038 --- How Many Answers Are Wrong] Weighted disjoint-set

Topic Source: Click to enter [HDU 3038 - How Many Answers Are Wrong]

Description

TT and FF are … friends. Uh… very very good friends -________-b

FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored).

Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF’s question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers.

BoringBoringa very very boring game!!! TT doesn’t want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose.

The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence.

However, TT is a nice and lovely girl. She doesn’t have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed.

What’s more, if FF finds an answer to be wrong, he will ignore it when judging next answers.

But there will be so many questions that poor FF can’t make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy)

Input

Line 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions.

Line 2…M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It’s guaranteed that 0 < Ai <= Bi <= N.

You can assume that any sum of subsequence is fit in 32-bit integer.

Output

A single line with a integer denotes how many answers are wrong.

Sample Input

10 5
1 10 100
7 10 28
1 3 32
4 6 41
6 6 1

Sample Output

1

Problem-solving ideas

We construct a weighted disjoint-set, the array is represented by a sum of the ancestor node to node exists between the number of nodes.
Each node should save the relationship between its parent and parent as well as his. Suppose root with a root node, SUM [i] denotes the i and the root node, then the sum [j] - sum [i -1] can be obtained the interval [i, J] and. Then given (a, b, s) may be regarded as a node b to a-1 and is s.
In the process of consolidation and find update sum array, respectively.

AC Code:

#include <iostream>
#include <algorithm>
using namespace std;
#define SIS std::ios::sync_with_stdio(false),cin.tie(0),cout.tie(0)
#define endl '\n'
const int MAXN = 2e5+5;
int sum[MAXN],pre[MAXN];

void init(int n)
{
    for(int i=0;i<=n;i++)
        pre[i]=i,sum[i]=0;
}

int _find(int x)
{
    if(pre[x]==x) return x;
    int p=pre[x];
    pre[x]=_find(pre[x]);
    sum[x]+=sum[p];
    return pre[x];
} 

int main()
{
    SIS;
    int n,m,a,b,s;
    while(cin >> n >> m)
    {
        init(n);
        int ans=0;
        while(m--)
        {
            cin >> a >> b >> s;
            a--;
            int x=_find(a);
            int y=_find(b);
            if(x==y && sum[b]-sum[a]!=s) ans++;
            else if(x!=y)
            {
                pre[y]=x;
                sum[y]=sum[a]-sum[b]+s;
            }
        }
        cout << ans << endl;
    }
    return 0;
}
Published 412 original articles · won praise 135 · views 40000 +

Guess you like

Origin blog.csdn.net/qq_41879343/article/details/104164065