And check HDU__1213 How Many Tables

How Many Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 40259    Accepted Submission(s): 20106


Problem Description
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
 

Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
 

Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
 

Sample Input
 
  
2 5 3 1 2 2 3 4 5 5 1 2 5
 

Sample Output
 
  
2 4

People who know each other sit at a table and ask how many tables are needed in total, (regardless of how many people the table can accommodate)

first row t

next line n and m

n is the number of people, and the following m lines represent the relationship



Introductory Topics for Consolidation

//#include<bits/stdc++.h>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<iostream>
using namespace std;
const int MAXN=1e3+3;
int pre[MAXN];
int t,n,m;
void init(int n)//initialization
{
	for(int i=1;i<=n;i++)
		pre[i]=i;
}
int find(int x)//Find the root
{
	return pre[x]==x?x:pre[x]=find(pre[x]);
}
void join(int x,int y)//connection
{
	x=find(x);
	y=find(y);
	if(x!=y)	pre[x]=y;
}
intmain()
{
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d %d",&n,&m);
		init(n);
		
		for(int i=0;i<m;i++)
		{
			int x,y;
			scanf("%d %d",&x,&y);
			join(x,y);
		}
		int ans=0;
		for(int i=1;i<=n;i++)
			if(pre[i]==i)	ans++;
		cout<<ans<<endl;
	}
	return 0;
}

Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=325744125&siteId=291194637