HDU - 3635 Weighted disjoint-set

Dragon Balls

Five hundred years later, the number of dragon balls will increase unexpectedly, so it's too difficult for Monkey King(WuKong) to gather all of the dragon balls together.

His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities' dragon ball(s) would be transported to other cities. To save physical strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls.
Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the ball has been transported so far.

Input
The first line of the input is a single positive integer T(0 < T <= 100).
For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000).
Each of the following Q lines contains either a fact or a question as the follow format:
  T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different.
  Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)
 
Output
For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.
 
Sample Input
2
3 3
T 1 2
T 3 2
Q 2
3 4
T 1 2
Q 1
T 1 3
Q 1
 
Sample Output
Case 1:
2 3 0
Case 2:
2 2 1 3 3 2
 
     Meaning of the questions: given the N Pearl, i i Pearl in the city. T: x, y. Where the collection will be put on x y. Q: x. Where x is the set of queries: x where the collection; collection where the total number of elements x; x is the number of movements.
    Parsing: x where the collection directly to find its root. x where the number of elements in the collection: directly into the all [] array is maintained in the time of the merger.
      It is important how to count the number of times x is moved. Sample 2 is concerned, 1 2, 1 2 3.1 on the tree, and then connected to 13 actually connect 2 3, tim [2] ++, but Tim [1] has not changed. Therefore, the value to be added tim find () in the Update: tim [x] + = tim [pr [x]]. The number of the mobile node is itself a mobile number + the root node. That ancestor back up, to increase the number of transfers to future generations. And the code is still dealing with a little bit of meaning, is the join () in tim [fa] first ++, descendants of fa tim [], left the next operation to update.
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<set>
using namespace std;
const int maxn=2e4+10;
int pr[maxn],all[maxn],tim[maxn];
int n,m;
void init()
{
    for(int i=1;i<=n;i++)
    {
        pr[i]=i;
        all[i]=1;
        tim[i]=0;
    }
}
int find(int x)
{
    if(x==pr[x])
        return x;
    int fa=pr[x];
    pr[x]=find(pr[x]);
    tim[x]+=tim[fa];
    return pr[x];
}
void join(int a,int b)
{
    int fa=find(a),fb=find(b);
    if(fa!=fb)
    {
        pr[fa]=fb;
        all[fb]+=all[fa];
        tim[fa]++;
    }
    return ;
}
int main()
{
    int t;
    int ac=1;
    scanf("%d",&t);
    while(t--)
    {
        printf("Case %d:\n",ac++);
        scanf("%d%d",&n,&m);
        init();
        char ch[5];
        while(m--)
        {
        //    scanf("%c",&ch);
            scanf("%s",ch);    
            int x,y;            
            if(ch[0]=='T')
            {
                scanf("%d%d",&x,&y);
                join(x,y);
            }
            else
            {
                scanf("%d",&x);
                int mid=find(x);
                cout<<mid<<" "<<all[mid]<<" "<<tim[x]<<endl;
            }
        }
    }
}

 

Guess you like

Origin www.cnblogs.com/liyexin/p/12649957.html