F - A+B for Input-Output Practice (IV)

Your task is to Calculate the sum of some integers.

Input
Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed.

Output
For each group of input integers you should output their sum in one line, and with one line of output for each line in input.

Sample Input
4 1 2 3 4
5 1 2 3 4 5
0

Sample Output
10
15

在这里代码实现:
#include <iostream>
using namespace std;
int main(){
	int n,x,sum;
	while(cin>>n&&n!=0){
		sum=0;
		while(n--){
			cin>>x;
			sum+=x;
		}
		cout<<sum<<endl;
	}
	return 0;
}
//注意while套while实现输出插入代码片
发布了37 篇原创文章 · 获赞 0 · 访问量 398

猜你喜欢

转载自blog.csdn.net/weixin_45351699/article/details/104072753