C - A+B for Input-Output Practice (VIII)

Your task is to calculate the sum of some integers.
Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.
Output
For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.
Sample Input
3
4 1 2 3 4
5 1 2 3 4 5
3 1 2 3
Sample Output
10

15

6
两种思路

#include<stdio.h>
int main()
{
    int N,sum,i,n,X;
	int count=1;
    sum=0;
    scanf("%d",&X);
    while(~scanf("%d",&N))
	{
        for(i=1;i<=N;i++)
		{
			scanf("%d",&n);
			sum+=n;
		}
        printf("%d\n",sum);
        sum=0;
		count++;
		if(count>X)break;
	}
	return 0;
}
#include <stdio.h>
int main()
{
	int N1,N2,num,sum;
	scanf("%d",&N1);
	for(int i=1;i<=N1;i++)
	{
		while(scanf("%d",&N2)!=EOF)
		{
			sum=0;
			for(int j=1;j<=N2;j++)
			{
				scanf("%d",&num);
				sum+=num;
			}
			printf("%d\n",sum);
			if(i<N1)
				printf("\n");
			break;
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/JxufeCarol/article/details/83118940
今日推荐