YTU OJ 1092: A+B for Input-Output Practice (V)

题目描述

Your task is to calculate the sum of some integers.

输入

Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.

输出

For each group of input integers you should output their sum in one line, and with one line of output for each line in input.

样例输入

2
4 1 2 3 4
5 1 2 3 4 5

样例输出

10
15

提示

来源

freeproblemset

【AC代码】

import java.util.Arrays;
import java.util.Scanner;
public class Main {
	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner sc = new Scanner(System.in);
		int n=sc.nextInt();
		while (n>0) {
			n--;
			int a = sc.nextInt();
			int s[]=new int[a];
			int sum=0;
			for(int i=0;i<a;i++)
			{
				s[i]=sc.nextInt();
				sum+=s[i];
			}
			System.out.println(sum);	
		}
	}
}

猜你喜欢

转载自blog.csdn.net/mcp3128/article/details/81203920