G - A+B for Input-Output Practice (V)

Your task is to calculate the sum of some integers.

Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.

Output
For each group of input integers you should output their sum in one line, and with one line of output for each line in input.

Sample Input
2
4 1 2 3 4
5 1 2 3 4 5

Sample Output
10
15

#include <iostream>
using namespace std;
int main(){
	int m,n,x,sum;
	cin>>m;
	while((m--)&&cin>>n){
		sum=0;
		for(int i=0;i<n;i++){
			cin>>x;
			sum+=x;
		}
		cout<<sum<<endl;
	}
	return 0;
}
发布了37 篇原创文章 · 获赞 0 · 访问量 397

猜你喜欢

转载自blog.csdn.net/weixin_45351699/article/details/104072783