Complete Binary Search Tree(完全搜索二叉树)

  • The left subtree of a node contains only nodes with keys less than the node’s key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.
Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.
Output Specification:
For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4

思路:老数组排序,建立一个新的数组,对新数组中序遍历,按编号纳入老数组的元素,很简单的一题

#include<bits/stdc++.h>
using namespace std;
int a[1005];
int b[1005];
int num=1;
void deal(int t,int n)
{
 if(t>n) return ;
 deal(2*t,n);
 b[t]=a[num++];
 deal(2*t+1,n);
 return ;
}
int main()
{
 ios::sync_with_stdio(false);
 cin.tie(0);
 int n;
 cin>>n;
 for(int i=1;i<=n;i++){
  cin>>a[i];
 }
 sort(a+1,a+n+1);
 deal(1,n);
 for(int i=1;i<=n;i++){
  if(i==1)
  cout<<b[i];
  else
  cout<<' '<<b[i];
 }
 return 0;
}
发布了38 篇原创文章 · 获赞 5 · 访问量 867

猜你喜欢

转载自blog.csdn.net/Fooooooo/article/details/103455930