1064 Complete Binary Search Tree

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:
For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:
10
1 2 3 4 5 6 7 8 9 0
Sample Output:
6 3 8 1 5 7 9 0 2 4
读题的时候并没有想到完全二叉树,虽然看到了complete,接着看题意,虽然看到了完全二叉树,但是还是不会写。
这题主要是考察完全二叉树的性质的,首先读入数据然后再用这些数据构建完全二叉树,然后层次遍历。
完全二叉树的properties
1.用数组存储较方便,根节点为1(数组的下标)
2.完全二叉树的任意一个节点x,它的左孩子下标为2x,右孩子的下标为2x+1,
3.数组存放的顺序恰好为该完全二叉树的层次遍历的顺序
4.先序遍历完全二叉树得到的是有序序列
5.判断某个节点是否为叶子节点的标志:该节点的左孩子 > n,无需判断有孩子。如果判断某个节点是否为空的标志:该节点下标>n

总结:
这题完全考的是完全二叉树的性质,主要是递归建树要理解透彻
首先是递归,递归主要看的是根再合适插入(或者根据题目的要求),因为CST的的先序遍历得到的是有序序列,所以根据这个性质来递归建树,递归2大特性:递归边界和递归式,边界就是上面说的第5点,而递归式只要按照先序的顺序来对根进行插入,最后按顺序输出就可以了

#include<iostream>
#include<algorithm>
#include<vector>
const int maxn=1005;
using namespace std;
int CST[maxn],data[maxn],n,index;
void create(int root){
	if(root > n) return;
	create(root * 2);
	CST[root] = data[index++];
	create(root * 2 + 1);
}
int main(){
 	cin>>n;
 	for(int i=0;i<n;i++) cin>>data[i];
 	sort(data,data+n);
 	create(1);
 	for(int i=1;i<=n;i++){
 		if(i<n) cout<<CST[i]<<' ';
		else cout<<CST[i]; 
	 }
	return 0;
} 
发布了139 篇原创文章 · 获赞 3 · 访问量 8514

猜你喜欢

转载自blog.csdn.net/weixin_44270812/article/details/102960468