7-7 Complete Binary Search Tree

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/Authur520/article/details/84886068

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

    A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

    Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

    Output Specification:

    For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

    Sample Input:

    10
    1 2 3 4 5 6 7 8 9 0
    

    Sample Output:

    6 3 8 1 5 7 9 0 2 4

具体代码实现为:

#include<stdio.h>
#include<math.h>

int a[1005],T[1005];

void build(int ALeft,int ARight,int TRoot);

int main()
{
	int i,j,t,N;
	int first = 1;
	
	scanf("%d",&N);
	for(i=0; i<N; i++){
		scanf("%d",&a[i]);
	}
	/*冒泡排序*/
	for(j=1; j<N; j++){  //n个数排序,只进行n-1趟
		for(i=0; i<N-j; i++){  //每一趟中进行n-j次比较
			if(a[i] > a[i+1]){
				t = a[i];
				a[i] = a[i+1];
				a[i+1] = t;
			}
		}
	}
	build(0,N-1,0);  //建树 
	/*层序输出该完全二叉搜索树*/
	for(i=0; i<N; i++){
		if(first){
			first = 0;
			printf("%d",T[i]);
		}else{
			printf(" %d",T[i]);
		}
	}
	
	return 0;
 } 
 
int  GetLeftLength(int n)
{
	int h,x;
	int L;
	
	h = (int)(log(n+1)/log(2));  //n个结点所形成的除去最下面一层的完美二叉树的高度 
	x = n-(pow(2,h)-1);  //n个结点形成的完全二叉树最下面一层的结点个数 
	if(x > pow(2,h-1))  x = pow(2,h-1);  //如果x大于左子树最下面一层所能拥有的最大结点数,就使其等于它 
	L = pow(2,h-1)-1+x;  //左子树的结点个数 
	
	return L;
}
 
 void build(int ALeft,int ARight,int TRoot)
 {
 	int n,L;
 	int  LeftTRoot, RightTRoot;
 	
 	n = ARight-ALeft+1;  //当前剩余结点数量 
 	if( n == 0 )  return;
 	L = GetLeftLength(n);  //计算n个结点的完全二叉树当前结点的左子树有多少个结点
	T[TRoot] = a[ALeft+L];  //当前根结点的值 
	LeftTRoot = TRoot*2+1;  //当前根结点左子树的根结点(左儿子)的下标 
	RightTRoot = LeftTRoot+1;  //当前根结点右子树的根结点(右儿子)的下标
	
	build(ALeft,ALeft+L-1,LeftTRoot);
	build(ALeft+L+1,ARight,RightTRoot);
 }

猜你喜欢

转载自blog.csdn.net/Authur520/article/details/84886068