蓝桥杯 算法训练 区间k大数查询 ALGO-1

蓝桥杯 算法训练 区间k大数查询 ALGO-1

资源限制

时间限制:1.0s 内存限制:256.0MB

问题描述

给定一个序列,每次询问序列中第l个数到第r个数中第K大的数是哪个。

输入格式

第一行包含一个数n,表示序列长度。
第二行包含n个正整数,表示给定的序列。
第三个包含一个正整数m,表示询问个数。
接下来m行,每行三个数l,r,K,表示询问序列从左往右第l个数到第r个数中,从大往小第K大的数是哪个。序列元素从1开始标号。

输出格式

总共输出m行,每行一个数,表示询问的答案。

样例输入

5
1 2 3 4 5
2
1 5 2
2 3 2

样例输出

4
2

数据规模与约定

对于30%的数据,n,m<=100;
对于100%的数据,n,m<=1000;
保证k<=(r-l+1),序列中的数<=106。

#include <iostream>
#include <algorithm>
using namespace std;
bool cmp(int a,int b){
    return a > b ? true : false;
}
int main(){
    int n,m;
    int store[10005] = {0};
    cin>>n;
    for (int i = 1; i <= n; ++i) {
        cin>> store[i];
    }
    cin>>m;
    for (int i = 0; i < m; ++i) {
        int l,r,k;
        cin>>l>>r>>k;
        int temp[1005];
        int flag = 0;
        for (int j = l; j <= r; ++j)
            temp[flag++] = store[j];
        sort(temp,temp+(r-l+1),cmp);
        cout<<temp[k-1]<<endl;
    }
    return 0;
}
发布了139 篇原创文章 · 获赞 67 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/qq_43422111/article/details/104768474