Is It A Tree?—— POJ - 1308

原题连接
vjudge
A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.

There is exactly one node, called the root, to which no directed edges point.
Every node except the root has exactly one edge pointing to it.
There is a unique sequence of directed edges from the root to each node.
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.

在这里插入图片描述
In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.
Input
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.
Output
For each test case display the line “Case k is a tree.” or the line “Case k is not a tree.”, where k corresponds to the test case number (they are sequentially numbered starting with 1).
Sample Input
6 8 5 3 5 2 6 4
5 6 0 0

8 1 7 3 6 2 8 9 7 5
7 4 7 8 7 6 0 0

3 8 6 8 6 4
5 3 5 6 5 2 0 0
-1 -1
Sample Output
Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.
题目大意:

给出多组边,让你判断这是不是一棵树。边的信息以( 始点, 末点)的形式给出以(0,0)结束.,数据以(-1,-1)输入结束;
树的定义:树是指任意两个结点之间有且仅有一条路径的无向图。或者说,只要是没有回路的连通无向图就是树。

#include<stdio.h>
#include<string.h>
#define N 1000
int p[N]={0};
int find(int x)
{
	//return x==p[x]?x:p[x]=find(p[x]);
	while(x!=p[x])
	x=p[x];
	return x;
}
int fun(int x,int y)
{
	int fy,fx;
	fy=find(y);
	fx=find(x);
	if(fy!=fx)
	{
		p[fy]=fx;
	}
}
int main()
{
	int k,i,a,b,flag;
	int sum;
	k=1;
	while(1)
	{
		flag=0;
		while(scanf("%d %d",&a,&b)!=EOF&&a&&b)
		{
			if(a==-1||b==-1)
			return 0;
			if(p[a]==0) p[a]=a;
			if(p[b]==0) p[b]=b;
			if(find(a)==find(b)) flag=1;
			if(flag!=1)
			fun(a,b);
		}
		for(i=1,sum=0;i<=N;i++)
		{
			if(p[i]==i) sum++;
			p[i]=0;
		}
		if(sum>1||flag==1)
		printf("Case %d is not a tree.\n",k);
		else printf("Case %d is a tree.\n",k);
		k++;
	}
	return 0;
}
发布了81 篇原创文章 · 获赞 3 · 访问量 2756

猜你喜欢

转载自blog.csdn.net/weixin_44641254/article/details/104739251
今日推荐