POJ - 1308 Is It A Tree?

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.

There is exactly one node, called the root, to which no directed edges point.
Every node except the root has exactly one edge pointing to it.
There is a unique sequence of directed edges from the root to each node.
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.


In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output

For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input

6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1

Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.

题解:和小希迷宫差不多。。。给你各个连着的点,问能不能构成一棵树

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int f[100010],book[100010],mp[100010];
int getf(int u)
{
    if(f[u]!=u)
        f[u]=getf(f[u]);
    return f[u];
}
int mergee(int u,int v)
{
    int t1=getf(u),t2=getf(v);
    if(t1!=t2)
    {
        f[t2]=t1;
        return 1;
    }
    return 0;
}
int main()
{
    int a,b,o=1;
    while(~scanf("%d%d",&a,&b)&&(a!=-1||b!=-1))
    {
        int i,j;
        if(a==0&&b==0)
        {
            printf("Case %d is a tree.\n",o++);
            continue;
        }
        for(i=0; i<=100000; i++)
            f[i]=i;
        memset(book,0,sizeof(book));
        memset(mp,0,sizeof(mp));
        book[a]=1;
        book[b]=1;
        mp[b]++;//根节点入度为0(所以不记点a),其他点入度必须为1
        mergee(a,b);
        int flag=1;
        while(scanf("%d%d",&a,&b)&&(a||b))
        {
            book[a]=1;
            book[b]=1;
            mp[b]++;
            if(mergee(a,b)==0||mp[b]>1)
                flag=0;
        }
        if(flag==0)
            printf("Case %d is not a tree.\n",o++);
        else
        {
            int ans=0,sum=0;
            for(i=1; i<=100000; i++)
            {
                if(book[i]==1&&f[i]==i)
                    ans++;
                if(book[i]==1&&mp[i]==0)
                    sum++;
            }
            if(ans==1&&sum==1)
                printf("Case %d is a tree.\n",o++);
            else
                printf("Case %d is not a tree.\n",o++);
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/GJLfly/article/details/81542683
今日推荐