poj 2299 归并排序求逆数

Ultra-QuickSort
Time Limit: 7000MS   Memory Limit: 65536K
Total Submissions: 60457   Accepted: 22413

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence
9 1 0 5 4 ,

Ultra-QuickSort produces the output
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0
 
 

//这个题的意思是问你冒泡排序中交换值的次数,也就是让你求序列中的逆数对之和
//归并排序求逆数对,在二路归并的时候通过比较左右两边队头的值求得
//这题也可以通过树状数组来求解,参考博文http://blog.csdn.net/ultimater/article/details/7908328
#include<stdio.h>
#define  MAX 500005
int a[MAX];
long long ans;
void mergearray(int a[], int first, int mid, int last, int temp[])
{
	int i = first, j = mid + 1;
	int m = mid,   n = last;
	int k = 0;

	while (i <= m && j <= n)
	{
		if (a[i] < a[j])
			temp[k++] = a[i++];
		else
			{
			temp[k++] = a[j++];
			ans=ans+(mid-i+1);
			}
	}

	while (i <= m)
		temp[k++] = a[i++];

	while (j <= n)
		temp[k++] = a[j++];

	for (i = 0; i < k; i++)
		a[first + i] = temp[i];
}
void mergesort(int a[], int first, int last, int temp[])
{
	if (first < last)
	{
		int mid = (first + last) / 2;
		mergesort(a, first, mid, temp);    //左边有序
		mergesort(a, mid + 1, last, temp); //右边有序
		mergearray(a, first, mid, last, temp); //再将二个有序数列合并
	}
}
bool MergeSort(int a[], int n)
{
	int *p = new int[n];
	if (p == NULL)
	return false;
	mergesort(a, 0, n, p);
	return true;
}
int main()
{
	int T;
	while(scanf("%d",&T)!=EOF&&T!=0)
	{
		ans=0; 
		for(int i=0;i<T;i++)
		{
			scanf("%d",&a[i]);
		}
		MergeSort(a,T-1);
		printf("%lld\n",ans);
	} 
	return 0;
} 


发布了34 篇原创文章 · 获赞 109 · 访问量 12万+

猜你喜欢

转载自blog.csdn.net/huihui1094667985/article/details/70918701
今日推荐