POJ 2299(逆序对)

Ultra-QuickSort
Time Limit: 7000MS   Memory Limit: 65536K

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 
9 1 0 5 4 ,

Ultra-QuickSort produces the output 
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

Source

代码:


#include<iostream>
using namespace std;
int tmp[500001],a[500001];
long long tot=0;
void sss(int l,int r)
{
if(l==r)return;
int mid=(l+r)/2,i=l,j=mid+1,p=l-1;
    sss(l,mid);
sss(mid+1,r);
while(i<=mid&&j<=r)
if(a[i]<=a[j])
{
tmp[++p]=a[i++];
tot+=j-mid-1;
}
else tmp[++p]=a[j++];
while(i<=mid)
{
tmp[++p]=a[i++];
tot+=r-mid;
}
while(j<=r)tmp[++p]=a[j++];
for(i=l;i<=r;i++)a[i]=tmp[i];
}
int main()
{
int i,n;
out:;
cin>>n;
tot=0;
if(n==0)return 0;
for(i=1;i<=n;i++)cin>>a[i];
sss(1,n);
cout<<tot<<endl;
goto out;
}

猜你喜欢

转载自blog.csdn.net/niuniu0205/article/details/80675256
今日推荐