POJ 2299 Ultra-QuickSort 使用归并排序 逆序对 OJ题解

一、题目背景

此题使用归并排序即可求解,需要在理解题意的基础上熟练掌握归并排序的算法。题目来源为POJ 2299,链接为:http://poj.org/problem?id=2299

二、题目描述

Problem Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence

9 1 0 5 4 ,

Ultra-QuickSort produces the output

0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 – the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

Source

Waterloo local 2005.02.05

三、求解思路

题目翻译下意思是,存在某种特定的排序算法,通过交换两个相邻的序列元素来处理 n 个不同整数的序列,直到该序列按升序排序。例如 9 1 0 5 4 会输出为 0 1 4 5 9 ,题目中管这个方法叫“Ultra-QuickSort ”,确定 Ultra-QuickSort 需要执行多少交换操作才能对给定的输入序列进行排序。

本题可以理解成,给定无序数组,求解经过最少多少次的相邻元素的交换,可以使数组从小到大有序。注意不要被不要被“QuickSort”这个词迷惑,该题使用的方法跟快排无关,而是归并排序的变形。如下图所示,输入的一组测试用例中,5为当前测试用例里的数组元素个数,43123为给定的无序数组,排序后应为12334,每个数到正确顺序的位置需要对换的次数为01221,因此结果输出为6

如果下面的过程看不懂的,建议先去仔细学一下基本的归并排序的知识点,再来做这道题,会有很大的帮助。数组中,相邻的两个元素如果满足前面的大于后面的,则肯定要交换一次,因为最终位置是小的在前,大的在后。如果存在正整数 i, j 使得 1 ≤ i < j ≤ n 而且 A[i] > A[j],则 <A[i], A[j]> 这个有序对称为 A 的一个逆序对,也称作逆序数。本题求解数组里逆序对的数目就是最少相邻元素的交换次数。

在归并排序中,将已有序的子序列合并,得到完全有序的序列;即先使每个子序列有序,再使子序列段间有序。若将两个有序表合并成一个有序表,称为二路归并。在二分区间的过程中,最小区间只有2个数,此时比较如果需要交换的话,就设置ans变量进行++的操作。若某个数向前移动了N位,则必定存在N个逆序数,ans也会统计记录N的值,最后输出这个记录下来的数即可得求解该题。

四、AC代码

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define ll long long
const int N=5e5+10;
ll arrays[N],temp[N],ans;

/*归并*/
void merge(ll arrays[],int left,int middle,int right){
    
    
    int i=left,j=middle+1,k=left;
    while(i<=middle&&j<=right){
    
    
        if(arrays[i]<=arrays[j]){
    
    
            temp[k++]=arrays[i++];
        }else{
    
    
            ans+=j-k;//改动归并排序的地方,设置ans变量
            temp[k++]=arrays[j++];
        }
    }
    while(i<=middle) temp[k++]=arrays[i++];
    while(j<=right) temp[k++]=arrays[j++];
    for(int i=left;i<=right;i++) arrays[i]=temp[i];//排序完成后赋值原数组
}

/*排序*/
void mergesort(ll arrays[],int left,int right){
    
    
    if(left<right){
    
    
        int middle=(left+right)/2;
        mergesort(arrays,left,middle);
        mergesort(arrays,middle+1,right);
        merge(arrays,left,middle,right);
    }
}

/*主函数*/
int main(){
    
    
    int n;
    while(~scanf("%d",&n)&&n){
    
    
        for(int i=1;i<=n;i++){
    
    
            scanf("%lld",&arrays[i]);
        }
        ans=0;
        mergesort(arrays,1,n);
        printf("%lld\n",ans);
    }
    return 0;
}

五、WA过程

需要注意以下错误:

  1. line 5 多加分号,line 6 数据范围错误;
  2. line 11 设置j的值没有+1
  3. line 12 比较临界点没有写=
  4. line 22 初始化和循环条件错误;
  5. line 38 输入包含多个测试用例;


祝看到这里的每一个人头发多多~

猜你喜欢

转载自blog.csdn.net/Eechoecho/article/details/120598878