Cable master

Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to connect computers for the contestants using a "star" topology - i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance from it. 
To buy network cables, the Judging Committee has contacted a local network solutions provider with a request to sell for them a specified number of cables with equal lengths. The Judging Committee wants the cables to be as long as possible to sit contestants as far from each other as possible. 
The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter,and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not known and the Cable Master is completely puzzled. 
You are to help the Cable Master, by writing a program that will determine the maximal possible length of a cable piece that can be cut from the cables in the stock, to get the specified number of pieces.
Input
The first line of the input file contains two integer numbers N and K, separated by a space. N (1 = N = 10000) is the number of cables in the stock, and K (1 = K = 10000) is the number of requested pieces. The first line is followed by N lines with one number per line, that specify the length of each cable in the stock in meters. All cables are at least 1 meter and at most 100 kilometers in length. All lengths in the input file are written with a centimeter precision, with exactly two digits after a decimal point.
Output
Write to the output file the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pieces. The number must be written with a centimeter precision, with exactly two digits after a decimal point. 
If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output file must contain the single number "0.00" (without quotes).
Sample Input
4 11
8.02
7.43
4.57
5.39
Sample Output

2.00 


这是一道题干巨恶心的题目。其实就是很简单地给N根长度不同的东西,要求削出K根长度相同的短东西,问满足条件的这K根的最大长度是多少,这个长度最小是0.01,如果不能满足这个条件,就输出0.00.

判断长度mid是否能够满足条件的函数,只要用a[i]/mid然后把i从1到N全部经历一遍相加就行。a[i]/mid是double型的,需要转成整形,这里我用的是向下取整方便理解,其实用(int)强制转换也不是四舍五入,在这里等效于floor

程序中先判断0.01能不能削出K根,如果不行的话就不用继续往下判断了。

直接输出.2lf是一个四舍五入的过程,这就会导致问题,比如数据是3.766,如果直接printf,就会变成3.77,而在这个实际问题里面明显是要用尾数截去法,只能取大不能取小。我的做法是把答案*100后向下取整,再/100,就达到了截掉三位以后小数的目的

#include<iostream>
#include<cstdio>
#include<cmath>
#define INF 0x3f3f3f3f
#define ESP 1e-10
using namespace std;
double a[10003];
int N,K;
bool judge(double mid)
{
    double sum=0;
    for(int i=1;i<=N;i++)
    sum+=floor((a[i]/mid));
    //cout<<sum<<endl;
    return sum>=K;
}
int main()
{
    cin>>N>>K;
    double mid;
    for(int i=1;i<=N;i++)
    {
        cin>>a[i];
    }
    if(!judge(0.01)) {cout<<"0.00"<<endl;return 0;}
    double lb=0.00,ub=INF;
    while(ub-lb>ESP)
    {
        mid=(ub+lb)/2;
        if(judge(mid)) lb=mid;
        else ub=mid;
        //cout<<lb<<' '<<ub<<endl;
    }
    ub=floor(ub*=100);//这一手很关键 像2.005这个数据 是不能直接输出.2lf的 因为不能四舍五入而是要直接去掉才对
    ub/=100.;
    printf("%.2lf\n",ub);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/xuzonghao/article/details/79795456