PAT basic 1042 字符统计 (20分) C++

一、题目描述

请编写程序,找出一段给定文字中出现最频繁的那个英文字母。

输入格式:
输入在一行中给出一个长度不超过 1000 的字符串。字符串由 ASCII 码表中任意可见字符及空格组成,至少包含 1 个英文字母,以回车结束(回车不算在内)。

输出格式:
在一行中输出出现频率最高的那个英文字母及其出现次数,其间以空格分隔。如果有并列,则输出按字母序最小的那个字母。统计时不区分大小写,输出小写字母。

输入样例:
This is a simple TEST. There ARE numbers and other symbols 1&2&3…

输出样例:
e 7

二、代码

//1042
#define _CRT_SECURE_NO_WARNINGS
#include<stdlib.h>
#include<string>
#include<map>
#include<cctype>
#include<iostream>
using namespace std;

int main()
{
	map<char, int> a;
	string s;
	getline(cin, s);
	for (int i = 0; i < s.size(); i++)
	{
		if (isalpha(s[i])) 
		{
			if (isupper(s[i]))
				s[i] += 32;
			a[s[i]]++;
		}
	}
	int max = 0;
	char maxchar;
	for (auto it = a.begin() ;it!=a.end();it++)
	{
		if (it->second > max)
		{
			maxchar = it->first;
			max = it->second;
		}
	}
	cout << maxchar << " " << max;
	system("pause");
	return 0;
}

三、运行结果

在这里插入图片描述

题目合集

在这里呦~

发布了81 篇原创文章 · 获赞 2 · 访问量 2003

猜你喜欢

转载自blog.csdn.net/qq_44352065/article/details/104119967
今日推荐