PAT 1042 字符统计

https://pintia.cn/problem-sets/994805260223102976/problems/994805280817135616

请编写程序,找出一段给定文字中出现最频繁的那个英文字母。

输入格式:

输入在一行中给出一个长度不超过1000的字符串。字符串由ASCII码表中任意可见字符及空格组成,至少包含1个英文字母,以回车结束(回车不算在内)。

输出格式:

在一行中输出出现频率最高的那个英文字母及其出现次数,其间以空格分隔。如果有并列,则输出按字母序最小的那个字母。统计时不区分大小写,输出小写字母。

输入样例:

This is a simple TEST.  There ARE numbers and other symbols 1&2&3...........

输出样例:

e 7

代码:
#include <bits/stdc++.h>

using namespace std;

const int maxn=1e5+10;
char s[maxn];
int c[30];

int main()
{
    int cnt;
    char ans;
    int maxx1=0;
    cin.getline(s, maxn);
    int len = strlen(s);
    for(int i=0;i<len;i++)
    {
        if(s[i]-'a'>=0&&s[i]-'a'<=26)
            c[s[i]-'a']++;
        if(s[i]-'A'>=0&&s[i]-'A'<=26)
            c[s[i]-'A']++;
    }
    for(int i=0;i<=25;i++)
    {
        if(c[i]>maxx1)
        {
            maxx1=c[i];
            cnt=i+1;
        }
    }
    ans=cnt+96;
    printf("%c %d",ans,maxx1);
    return 0;
}

  

猜你喜欢

转载自www.cnblogs.com/zlrrrr/p/9364071.html