PAT-B1042 字符统计(20)

1042 字符统计(20)(20 分)

请编写程序,找出一段给定文字中出现最频繁的那个英文字母。

输入格式:

输入在一行中给出一个长度不超过1000的字符串。字符串由ASCII码表中任意可见字符及空格组成,至少包含1个英文字母,以回车结束(回车不算在内)。

输出格式:

在一行中输出出现频率最高的那个英文字母及其出现次数,其间以空格分隔。如果有并列,则输出按字母序最小的那个字母。统计时不区分大小写,输出小写字母。

输入样例:

This is a simple TEST.  There ARE numbers and other symbols 1&2&3...........

输出样例:

e 7

分析:不区分大小写。

代码:

#include <string>
#include <map>
#include <cctype>

using namespace std;

int main()
{
    string input;
    map<char, int> inf;
    int i;
    pair<char, int> most;//记录当前出现次数最多的字符和次数
    
    getline(cin, input);
    most.second = -1;
    for(i = 0; i < input.size(); i++)
    {
        if(!isalpha(input[i]))
            continue;
        input[i] = tolower(input[i]);
        if(inf.find(input[i]) == inf.end())
        {
            inf[input[i]] = 1;
            if(most.second < 0)
                most = pair<char, int>(input[i], 1);
        }
        else
        {
            inf[input[i]] += 1;
            if(most.second < inf[input[i]])
                most = pair<char, int>(input[i], inf[input[i]]);
            else if(most.second == inf[input[i]])
                if(most.first > input[i])
                    most.first = input[i];
        }
    }
    cout << most.first << " " << most.second;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_38127801/article/details/81043582
今日推荐