HDU6666 Quailty and CCPC

Problem Description
Considering the overall difficulty of other problems, we invite Quailty to propose an easy problem for this contest.
Quailty accidentally won both gold medal and silver medal in 2017 CCPC final. The reason is explained as follows. According to the official rule, the number of gold medals was 10% of the number of participating teams, rounded to the nearest integer. This is ambiguous when the fractional part of the result is exactly 0.5. There were 115 participating teams, and the rank of Quailty’s team was 12. The organizer originally decided to round down the number, so there were only 11 gold medals, and Quailty’s team could only win the silver medal. Many people defended him against the organizer, saying that his team deserved a gold medal. Later, the organizer changed to round up the number, and Quailty’s team finally won a gold medal.
Now, give you the scoreboard of a contest and the proportion of gold medal teams, could you determine whether there exists a team, such that they would win a gold medal were the number of gold medals rounded up when the fractional part is exactly 0.5, and silver medal if rounded down?
A team ranks before another if they solved more problems or both teams solved an equal number of problems but they had less penalty time.
(Disclaimer: the background is fictitious and the problem is prepared by Nanjing University ICPC Training Team, not Quailty.)
Input
The first line of input consists of a single integer T (1≤T≤120), denoting the number of test cases.
Each test case starts with a line of two integers n (1≤n≤105), denoting the number of participating teams, and d (0≤d≤9), denoting that the proportion of gold medal teams is 10d%. For the next n lines, each containing a string s and two integers p,t (0≤p,t≤109), denoting the name of the team, the number of problems solved and the penalty time of the team, respectively. The name of the each team contains at least 1 and at most 10 latin letters. The names are case sensitive. No two teams have the same name. No two teams have the same penalty time. The sum of n over all test cases does not exceed 106.
Output
For each test case, print the team name if there exists such team, or print Quailty is very great otherwise. It can be proved that there is at most one such team.
Sample Input
2
5 1
Ace 1000 0
Luffy 999 1
Sabo 998 2
Roronoa 997 3
Sanji 996 4
2 3
You 0 0
I 10 1
Sample Output
Ace
Quailty is very great
 

题意:给出n值队伍的队名,A题数量和罚时以及金奖的比例,问是否存在一支队伍,在原来人数乘比例后人数是.5的情况,如果是,输出这只队伍的名字,否则输出Quailty is very great。

思路:先判断是否存在.5这种情况,如果不存在直接continnue,存在的话再sort排序,否则会超时

反思:我就是铁憨憨,看样例猜题意,然后完完全全理解错了。下次别急,稳住啊兄弟。

#include<iostream>
#include<algorithm>
#include<cmath>
using namespace std;
struct Team{
	char name[10];
	int prob;
	int time;
}team[100000]; 
bool cmp(Team a,Team b) {
	if(a.prob==b.prob)	
		return a.time<b.time;
	return a.prob>b.prob;
}
int main() {
	int T;
	scanf("%d",&T);
	while(T--) {
		int n,d;
		scanf("%d%d",&n,&d);
		for(int i=0;i<n;i++) {
			scanf("%s%d%d",team[i].name,&team[i].prob,&team[i].time);
		}
		double num1=(n*d)/10.0;
		int fal=floor(num1);
		if((num1-fal)!=0.5) {
			cout<<"Quailty is very great"<<endl;
			continue;
		}
		sort(team,team+n,cmp);
		
		cout<<team[fal].name<<endl;	
	} 
	return 0;
} 
发布了87 篇原创文章 · 获赞 56 · 访问量 9146

猜你喜欢

转载自blog.csdn.net/Ven21959/article/details/102396061