POJ 2112 Optimal Milking 二分 + 多重匹配 +Floyd

一、内容

FJ has moved his K (1 <= K <= 30) milking machines out into the cow pastures among the C (1 <= C <= 200) cows. A set of paths of various lengths runs among the cows and the milking machines. The milking machine locations are named by ID numbers 1..K; the cow locations are named by ID numbers K+1..K+C.

Each milking point can "process" at most M (1 <= M <= 15) cows each day.

Write a program to find an assignment for each cow to some milking machine so that the distance the furthest-walking cow travels is minimized (and, of course, the milking machines are not overutilized). At least one legal assignment is possible for all input data sets. Cows can traverse several paths on the way to their milking machine.

Input

* Line 1: A single line with three space-separated integers: K, C, and M.

* Lines 2.. ...: Each of these K+C lines of K+C space-separated integers describes the distances between pairs of various entities. The input forms a symmetric matrix. Line 2 tells the distances from milking machine 1 to each of the other entities; line 3 tells the distances from machine 2 to each of the other entities, and so on. Distances of entities directly connected by a path are positive integers no larger than 200. Entities not directly connected by a path have a distance of 0. The distance from an entity to itself (i.e., all numbers on the diagonal) is also given as 0. To keep the input lines of reasonable length, when K+C > 15, a row is broken into successive lines of 15 numbers and a potentially shorter line to finish up a row. Each new row begins on its own line.

Output

A single line with a single integer that is the minimum possible total distance for the furthest walking cow.

Sample Input

2 3 2
0 3 2 1 1
3 0 3 2 0
2 3 0 1 0
1 2 1 0 2
1 0 0 2 0

Sample Output

2

二、思路

  • 每个奶牛到机器的最短距离我们先用floyd处理出来。
  • 每个机器可以匹配m个奶牛。 然后我们可以二分最短的距离。

三、代码

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int N = 250, INF = 0x3f3f3f3f;
struct Node {
	int len, my[20];
} mat[N];
int K, C, m, g[N][N];
bool vis[N];
bool dfs(int u, int mid) {
	for (int v = 1; v <= K; v++) {
		if (vis[v] || g[u][v] > mid) continue; vis[v] = true;
		if (mat[v].len < m) {
			mat[v].my[++mat[v].len] = u;
			return true;
		}
		for (int i = 1; i <= mat[v].len; i++) {
			if (dfs(mat[v].my[i], mid)) {
				mat[v].my[i] = u; return true;
			}
		}
	}
	return false;
}
bool ok(int mid) {
	for (int i = 1; i <= K + C; i++) mat[i].len = 0;
	for (int i = K + 1; i <= K + C; i++) {
		memset(vis, false, sizeof(vis));
		if (!dfs(i, mid)) return false;
	}
	return true;
}
int main() {
	while (~scanf("%d%d%d", &K, &C, &m)) { 
		memset(g, 0x3f, sizeof(g));
		for (int i = 1; i <= K + C; i++) {
			for (int j = 1; j <= K + C; j++) {
				scanf("%d", &g[i][j]);	
				if (g[i][j] == 0) g[i][j] = INF;
	 		}
		}	
		//求出各点的最短距离 
		for (int k = 1; k <= K + C; k++) {
			for (int i = 1; i <= K + C; i++) {
				for (int j = 1; j <= K + C; j++) g[i][j] = min(g[i][j], g[i][k] + g[k][j]);
			}
		}
		int l = 0, r = INF;
		while (l < r) {
			int mid = (l + r) >> 1;
			if (ok(mid)) {
				r = mid;
			} else {
				l = mid + 1;
			}
		} 
		printf("%d\n", r);
	}
	return 0;
} 
发布了471 篇原创文章 · 获赞 481 · 访问量 7万+

猜你喜欢

转载自blog.csdn.net/qq_41280600/article/details/104543439