POJ - 2112 Optimal Milking(floyd传递闭包+二分枚举+二分图多重匹配)

                                                                             Optimal Milking

Time Limit: 2000MS   Memory Limit: 30000K
Total Submissions: 19622   Accepted: 7022
Case Time Limit: 1000MS

Description

FJ has moved his K (1 <= K <= 30) milking machines out into the cow pastures among the C (1 <= C <= 200) cows. A set of paths of various lengths runs among the cows and the milking machines. The milking machine locations are named by ID numbers 1..K; the cow locations are named by ID numbers K+1..K+C. 

Each milking point can "process" at most M (1 <= M <= 15) cows each day. 

Write a program to find an assignment for each cow to some milking machine so that the distance the furthest-walking cow travels is minimized (and, of course, the milking machines are not overutilized). At least one legal assignment is possible for all input data sets. Cows can traverse several paths on the way to their milking machine. 

Input

* Line 1: A single line with three space-separated integers: K, C, and M. 

* Lines 2.. ...: Each of these K+C lines of K+C space-separated integers describes the distances between pairs of various entities. The input forms a symmetric matrix. Line 2 tells the distances from milking machine 1 to each of the other entities; line 3 tells the distances from machine 2 to each of the other entities, and so on. Distances of entities directly connected by a path are positive integers no larger than 200. Entities not directly connected by a path have a distance of 0. The distance from an entity to itself (i.e., all numbers on the diagonal) is also given as 0. To keep the input lines of reasonable length, when K+C > 15, a row is broken into successive lines of 15 numbers and a potentially shorter line to finish up a row. Each new row begins on its own line. 

Output

A single line with a single integer that is the minimum possible total distance for the furthest walking cow. 

Sample Input

2 3 2
0 3 2 1 1
3 0 3 2 0
2 3 0 1 0
1 2 1 0 2
1 0 0 2 0

Sample Output

2

Source

USACO 2003 U S Open

       这道先用floyd求的出任意两点间的最短路,然后进行二分枚举最大值进行二分图多重匹配就好了;

       不过这道题数据有点问题。。。你的枚举上限要开到20000(至少我是这个数),然后其他的数组也要相应地开打到1000左右。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<vector>
using namespace std;
#define inf 20000
int vis[1005];
int G[1050][1050];
vector<int>use[1005];
int n, m, p;
void floyd(){
	for (int s = 1; s <= n + m; s++) 
		for (int w = 1; w <= n + m; w++) 
			for (int q = 1; q <= n + m; q++)
				if (G[w][q] > G[w][s] + G[s][q])
					G[w][q] = G[w][s] + G[s][q];
}
bool find(int x,int limit) {
	for (int s = 1; s <= n; s++) {
		if (!vis[s] && G[s][x+n] <= limit) {
			vis[s] = 1;
			if (use[s].size() < p) {
				use[s].push_back(x); return 1;
			}
			for (int w = 0; w < use[s].size(); w++) {
				if (find(use[s][w], limit)) {
					use[s][w] = x; return 1;
				}
			}
		}
	}
	return 0;
}
bool check(int x) {
	for (int s = 0; s <= n; s++) 
		use[s].clear();
	for (int s = 1; s <= m; s++) {
		memset(vis, 0, sizeof(vis));
		if (!find(s,x))
			return 0;
	}
	return 1;
}
int main()
{
	while (~scanf("%d%d%d", &n, &m, &p)) {
		for (int s = 1; s <= n + m; s++)
			for (int w = 1; w <= n + m; w++){
				scanf("%d", &G[s][w]);
				if (G[s][w] == 0)G[s][w] = inf;
			}
		floyd();		
		int li = 0, ri = 20000;
		while (li < ri) {
			int mid = (li + ri) >> 1;
			if (check(mid))
				ri = mid;
			else
				li = mid + 1;
		}
		cout << ri << endl;
	}
}

猜你喜欢

转载自blog.csdn.net/chenshibo17/article/details/81463565