poj 2112Optimal Milking(最短路加网络流加二分)

Optimal Milking

Time Limit: 2000MS   Memory Limit: 30000K
Total Submissions: 20392   Accepted: 7273
Case Time Limit: 1000MS

Description

FJ has moved his K (1 <= K <= 30) milking machines out into the cow pastures among the C (1 <= C <= 200) cows. A set of paths of various lengths runs among the cows and the milking machines. The milking machine locations are named by ID numbers 1..K; the cow locations are named by ID numbers K+1..K+C. 

Each milking point can "process" at most M (1 <= M <= 15) cows each day. 

Write a program to find an assignment for each cow to some milking machine so that the distance the furthest-walking cow travels is minimized (and, of course, the milking machines are not overutilized). At least one legal assignment is possible for all input data sets. Cows can traverse several paths on the way to their milking machine. 

Input

* Line 1: A single line with three space-separated integers: K, C, and M. 

* Lines 2.. ...: Each of these K+C lines of K+C space-separated integers describes the distances between pairs of various entities. The input forms a symmetric matrix. Line 2 tells the distances from milking machine 1 to each of the other entities; line 3 tells the distances from machine 2 to each of the other entities, and so on. Distances of entities directly connected by a path are positive integers no larger than 200. Entities not directly connected by a path have a distance of 0. The distance from an entity to itself (i.e., all numbers on the diagonal) is also given as 0. To keep the input lines of reasonable length, when K+C > 15, a row is broken into successive lines of 15 numbers and a potentially shorter line to finish up a row. Each new row begins on its own line. 

Output

A single line with a single integer that is the minimum possible total distance for the furthest walking cow. 

Sample Input

2 3 2
0 3 2 1 1
3 0 3 2 0
2 3 0 1 0
1 2 1 0 2
1 0 0 2 0

Sample Output

2

Source

USACO 2003 U S Open

扫描二维码关注公众号,回复: 4740760 查看本文章
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
#include<queue>
using namespace std;
#define maxn 550
#define inf 1e9
struct edge
{int from,to,cap,flow;
edge(){}
edge(int f,int t,int c,int fl):from(f),to(t),cap(c),flow(fl){}
};
struct din
{
    int n,m,s,t;
    vector<edge>edges;
    vector<int>g[maxn];
    int d[maxn];
    bool vis[maxn];
    int cur[maxn];
    void init(int n,int s,int t)
    {
        this->n=n;
        this->s=s;
        this->t=t;
        edges.clear();
        for(int i=0;i<n;i++)
            g[i].clear();
    }
    void addedge(int from,int to,int cap)
    {
        edges.push_back(edge(from,to,cap,0));
        edges.push_back(edge(to,from,0,0));
        m=edges.size();
        g[from].push_back(m-2);
        g[to].push_back(m-1);
    }
    bool bfs()
    {
        queue<int>q;
        memset(vis,0,sizeof(vis));
        vis[s]=true;
        d[s]=0;
        q.push(s);
        while(!q.empty())
        {
            int x=q.front();
            q.pop();
            for(int i=0;i<g[x].size();i++)
            {
                edge&e=edges[g[x][i]];
                if(!vis[e.to]&&e.cap>e.flow)
                {
                    vis[e.to]=true;
                    d[e.to]=d[x]+1;
                    q.push(e.to);
                }
            }
        }
        return vis[t];
    }
    int dfs(int x,int a)
    {if(x==t||a==0)
    return a;
    int flow=0,f;
    for(int &i=cur[x];i<g[x].size();i++)
    {
        edge&e=edges[g[x][i]];
        if(d[e.to]==d[x]+1&&(f=dfs(e.to,min(a,e.cap-e.flow))>0))
        {
            e.flow+=f;
            edges[g[x][i]^1].flow-=f;
            flow+=f;
            a-=f;
            if(a==0)
                break;
        }

    }
    return flow;

    }
    int maxflow()
    {
        int ans=0;
        while(bfs())
        {
            memset(cur,0,sizeof(cur));
            ans+=dfs(s,inf);

        }
        return ans;
    }
}Dc;
int K,M,C;
int src,dst;
int dis[maxn][maxn];
void floyd(int n)
{
    for(int k=1;k<=n;k++)
        for(int i=1;i<=n;i++)
        for(int j=1;j<=n;j++)
        if(dis[i][k]<inf&&dis[k][j]<inf)
        dis[i][j]=min(dis[i][j],dis[i][k]+dis[k][j]);

}
bool solve(int limit)
{
    Dc.init(2+K+C,src,dst);
    for(int i=1;i<=C;i++)
        Dc.addedge(src,K+i,1);
    for(int i=1;i<=K;i++)
        Dc.addedge(i,dst,M);
for(int i=1;i<=C;i++)
    for(int j=1;j<=K;j++)
    if(dis[i+K][j]<=limit)
    Dc.addedge(i+K,j,1);
    return Dc.maxflow()==C;

}
int main()
{
    while(~scanf("%d%d%d",&K,&C,&M))
    {int n=K+C;
    src=0,dst=K+C+1;
    for(int i=1;i<=n;i++)
        for(int j=1;j<=n;j++)
        dis[i][j]=i==j?0:inf;
    for(int i=1;i<=n;i++)
        for(int j=1;j<=n;j++)
    {
        scanf("%d",&dis[i][j]);
        if(i!=j&&dis[i][j]==0)
            dis[i][j]=inf;
    }
    floyd(n);
    int L=0,R=0;
    for(int i=1;i<=n;i++)
        for(int j=i+1;j<=n;j++)
    {if(dis[i][j]<inf)
    R=max(R,dis[i][j]);

    }
    while(R>L)
    {
        int mid=L+(R-L)/2;
        if(solve(mid))
            R=mid;
        else
            L=mid+1;

    }
    printf("%d\n",R);

    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sdauguanweihong/article/details/85015206