PAT A1143 Lowest Common Ancestor (30分)

PAT甲级:A1143 Lowest Common Ancestor (30分)

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

A binary search tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node’s key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
  • Both the left and right subtrees must also be binary search trees.

Given any two nodes in a BST, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the BST, respectively. In the second line, N distinct integers are given as the preorder traversal sequence of the BST. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the BST, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found..

Sample Input:

6 8
6 3 1 2 5 4 8 7
2 5
8 7
1 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 5 is 3.
8 is an ancestor of 7.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.
  • 题意:给一个二叉搜索树的先序遍历序列,给出任意两结点值找到其最低公共祖先。
  • 分析:根据二叉搜索树的特性,按照题目中的定义,其根结点总是大于左子树的所有结点,且总大于或等于其右子树的所有结点。那么在寻找a、b结点的最低公共祖先时候可以遍历这棵树的所有结点,找到其值介于a、b之间(可等)的结点即可,因为给出的结点可能并不存在于树中,所以在读入先序序列的时候可以先对树中的结点做标记。之后如果不存在该结点便可直接判断。
#include <bits/stdc++.h>
using namespace std;
int main() {
    int n, m, a, b;
    scanf("%d%d", &n, &m);
    vector<int> pre(m);
    unordered_map<int, bool> exist;
    for (int i = 0; i < m; i++) {
        scanf("%d", &pre[i]);
        exist[pre[i]] = true;
    }
    while (n--) {
        scanf("%d%d", &a, &b);
        if (!exist[a] && !exist[b]) printf("ERROR: %d and %d are not found.\n", a, b);
        else if (!exist[a] || !exist[b]) printf("ERROR: %d is not found.\n", !exist[a] ? a : b);
        else {
            int ans = -1;
            for (int i = 0; i < m; i++) {
                ans = pre[i];
                if ((ans >= a && ans <= b) || (ans >= b && ans <= a)) break;
            }
            if (a == ans || b == ans) printf("%d is an ancestor of %d.\n", ans, a == ans ? b : a);
            else printf("LCA of %d and %d is %d.\n", a, b, ans);
        }
    }
    return 0;
}
发布了38 篇原创文章 · 获赞 0 · 访问量 580

猜你喜欢

转载自blog.csdn.net/charjindev/article/details/104482091