【PAT】A1143 Lowest Common Ancestor (30分)


作者: CHEN, Yue
单位: 浙江大学
时间限制: 200 ms
内存限制: 64 MB
代码长度限制: 16 KB

A1143 Lowest Common Ancestor (30分)

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

A binary search tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
Given any two nodes in a BST, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the BST, respectively. In the second line, N distinct integers are given as the preorder traversal sequence of the BST. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the BST, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found…

Sample Input:

6 8
6 3 1 2 5 4 8 7
2 5
8 7
1 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 5 is 3.
8 is an ancestor of 7.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

Code

#include <stdio.h>
#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
vector<int> pre,in;
struct NODE{
    int data;
    struct NODE *lchild,*rchild;
};
NODE *build(int preL,int preR,int inL,int inR){
    if(preL>preR)       return NULL;
    NODE *root=new NODE;
    root->data=pre[preL];
    int i;
    for(i=inL;i<=inR;i++){
        if(pre[preL]==in[i])
            break;
    }
    int lcnt=i-inL;
    root->lchild=build(preL+1,preL+lcnt,inL,i-1);
    root->rchild=build(preL+lcnt+1,preR,i+1,inR);
    return root;
}
bool findnode(int u){ //查找节点
    for(int i=0;i<pre.size();i++){
        if(u==pre[i])
         return true;
    }
    return false;
}
NODE *LCA(NODE *root, int u, int v) { //查找两节点最近祖先
    if(root==NULL)  return NULL;
    if(root->data==u||root->data==v)    return root;
    NODE *left=LCA(root->lchild,u,v);
    NODE *right=LCA(root->rchild,u,v);
    if(left&&right) return root; //u,v分别位于左右子树的情况
    return left==NULL ? right:left;
}
int main(){
    int m,n,u,v;
    scanf("%d %d",&m,&n);
    pre.resize(n);
    in.resize(n);
    for(int i=0;i<n;i++)    scanf("%d",&pre[i]);
    in=pre;
    sort(in.begin(),in.end());
    NODE *root=build(0,n-1,0,n-1);
    for(int i=0;i<m;i++){
        scanf("%d %d",&u,&v);
        if(findnode(u)==false && findnode(v)==false)  printf("ERROR: %d and %d are not found.\n",u,v);
        else if(findnode(u)==false) printf("ERROR: %d is not found.\n",u);
        else if(findnode(v)==false) printf("ERROR: %d is not found.\n",v);
        else{
            NODE *temp=LCA(root,u,v);
            if(u==temp->data)   printf("%d is an ancestor of %d.\n",u,v);
            else if(v==temp->data)  printf("%d is an ancestor of %d.\n",v,u);
            else    printf("LCA of %d and %d is %d.\n",u,v,temp->data);
        }
    }
    return 0;
}

Analysis

-已知一棵二叉排序树的前序,以及M组的两个结点。

-求每一组中,两个结点的最低公共祖先。

-和之后的A1151极其相似。

发布了159 篇原创文章 · 获赞 17 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/ztmajor/article/details/103866323