Day11 - M - Nim or not Nim? HDU - 3032

Nim is a two-player mathematic game of strategy in which players take turns removing objects from distinct heaps. On each turn, a player must remove at least one object, and may remove any number of objects provided they all come from the same heap.

Nim is usually played as a misere game, in which the player to take the last object loses. Nim can also be played as a normal play game, which means that the person who makes the last move (i.e., who takes the last object) wins. This is called normal play because most games follow this convention, even though Nim usually does not.

Alice and Bob is tired of playing Nim under the standard rule, so they make a difference by also allowing the player to separate one of the heaps into two smaller ones. That is, each turn the player may either remove any number of objects from a heap or separate a heap into two smaller ones, and the one who takes the last object wins.

InputInput contains multiple test cases. The first line is an integer 1 ≤ T ≤ 100, the number of test cases. Each case begins with an integer N, indicating the number of the heaps, the next line contains N integers s[0], s[1], ...., s[N-1], representing heaps with s[0], s[1], ..., s[N-1] objects respectively.(1 ≤ N ≤ 10^6, 1 ≤ S[i] ≤ 2^31 - 1)OutputFor each test case, output a line which contains either "Alice" or "Bob", which is the winner of this game. Alice will play first. You may asume they never make mistakes.Sample Input

2
3
2 2 3
2
3 3

Sample Output

Alice
Bob

思路:Multi-SG问题,我们打表找规律,然后用SG函数即可
#include<bits/stdc++.h>
using namespace std;
#define lowbit(x) ((x)&(-x))
typedef long long LL;

const int maxm = 1024;

int sg[maxm];
bool vis[maxm];

void run_case() {
    sg[0] = 0;
    for(int i = 1; i < maxm; ++i) {
        memset(vis, 0, sizeof(vis));
        for(int j = 0; j <= i; ++j) {
            vis[sg[j]] = true;
            if(j != i && j != 0) vis[sg[j]^sg[i-j]] = true;
        }
        
        for(int j = 0;;++j) {
            if(!vis[j])  {
                sg[i]=j;
                break;
            }
        }
    }
    for(int i = 0; i < maxm; ++i)
        cout << i << " " << sg[i] << "\n";
}

int main() {
    ios::sync_with_stdio(false), cin.tie(0);
    //int t; cin >> t;
    //while(t--)
    run_case();
    cout.flush();
    return 0;
}
打表

打表后可以发现规律,每4个一个轮回,1234 就是1243 5678就是5687 规律很显然

#include<bits/stdc++.h>
using namespace std;
#define lowbit(x) ((x)&(-x))
typedef long long LL;

int getsg(int x) {
    if(x%4 == 0) return x-1;
    else if(x%4 == 3) return x+1;
    return x;
}

void run_case() {
    int n, ans = 0, val;
    cin >> n;
    while(n--) {
        cin >> val;
        ans ^= getsg(val);
    }
    if(!ans) cout << "Bob\n";
    else cout << "Alice\n";
}

int main() {
    ios::sync_with_stdio(false), cin.tie(0);
    int t; cin >> t;
    while(t--)
    run_case();
    cout.flush();
    return 0;
}
View Code

猜你喜欢

转载自www.cnblogs.com/GRedComeT/p/12317607.html
Nim