HDU-3032--Nim or not Nim?(博弈+SG打表)

Problem Description
Nim is a two-player mathematic game of strategy in which players take turns removing objects from distinct heaps. On each turn, a player must remove at least one object, and may remove any number of objects provided they all come from the same heap.

Nim is usually played as a misere game, in which the player to take the last object loses. Nim can also be played as a normal play game, which means that the person who makes the last move (i.e., who takes the last object) wins. This is called normal play because most games follow this convention, even though Nim usually does not.

Alice and Bob is tired of playing Nim under the standard rule, so they make a difference by also allowing the player to separate one of the heaps into two smaller ones. That is, each turn the player may either remove any number of objects from a heap or separate a heap into two smaller ones, and the one who takes the last object wins.
 

Input
Input contains multiple test cases. The first line is an integer 1 ≤ T ≤ 100, the number of test cases. Each case begins with an integer N, indicating the number of the heaps, the next line contains N integers s[0], s[1], ...., s[N-1], representing heaps with s[0], s[1], ..., s[N-1] objects respectively.(1 ≤ N ≤ 10^6, 1 ≤ S[i] ≤ 2^31 - 1)
 

Output
For each test case, output a line which contains either "Alice" or "Bob", which is the winner of this game. Alice will play first. You may asume they never make mistakes.
 

Sample Input
 
  
232 2 323 3
 

Sample Output
 
  
AliceBob

个人觉得这道例题可以更好地理解SG函数打表

 题意:两人博弈,N堆石子,可以选择移走某一堆的任意数量的石子,也可以选择将这一堆分成任意两堆东西

解释在代码上:

#include <stdio.h>
#include <cstring>
#include <iostream>
using namespace std;
const int maxn = 1005;
int sg[maxn] , Hash[maxn] , F[maxn];
int N;
int fsg(int n)//通过打表找到的规律 
{
	if(n % 4 == 3)return n+1;
	else if(n % 4 == 0)return n-1;
	else return n;
}
int main()
{
	int t , res=0 ;
	while(~scanf("%d" , &t))//多组输入 
	{
		while(t--)
		{
			
			scanf("%d" , &N);//N堆 
			res = 0;
			memset(F , 0 , sizeof(F)); 
			for(int i =  0 ; i < N; i++)//每堆的数量 
			{
				scanf("%d" , &F[i]);
			
			}
			for(int i = 0 ; i < N ; i++)
			{
				res ^= fsg(F[i]);//每堆互相异或 
			}
		//	cout <<"res=" << res<<endl;
			if(res == 0)
			{
				printf("Bob\n");
			}
			else
			{
				printf("Alice\n");
			}
		}
	
	}
	
	return 0;
}

附上SG打表的代码:

void getsg()
{
	//nim博弈 , 选择的是任意连续的数字 , 因此在这里sg[x]=x
	memset(sg , 0 , sizeof(sg));
	sg[0] = 0 ;
	sg[1] = 1 ;
	for(int i = 1 ; i <= maxn ; i++)//每堆中有多少个石子,求出每个数量的sg值 
	{
		memset(Hash , 0 , sizeof(Hash));
		for(int j = 1 ; j <= i ; j++)
		{
			Hash[sg[i-j]] = 1;//取任意数量 
		}
		for(int j = 1 ; j < i ; j++)
		{
			Hash[sg[j] ^ sg[i-j]] = 1;//将石子分成两堆 
		}
		for(int j = 0 ; j <= maxn ; j++) 
		{
			if(Hash[j] == 0)
			{
				sg[i]= j;
				break;
			}
		}
		cout <<i  <<":" <<sg[i] << endl;
	}	
}

猜你喜欢

转载自blog.csdn.net/qq_41593380/article/details/80026791