pta 7-46 删除字符串中的子串 (20分)

输入2个字符串S1和S2,要求删除字符串S1中出现的所有子串S2,即结果字符串中不能包含S2。

输入格式:

输入在2行中分别给出不超过80个字符长度的、以回车结束的2个非空字符串,对应S1和S2。

输出格式:

在一行中输出删除字符串S1中出现的所有子串S2后的结果字符串。

输入样例:

Tomcat is a male ccatat
cat

输出样例:

Tom is a male 
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
using namespace std;
string str,s;
int pos;
int main(){
    getline(cin,str);
    getline(cin,s);
    while(str.find(s)!=-1){
        pos=str.find(s);
        str.erase(pos,s.length());
    }
    cout<<str;
    return 0;
}
发布了32 篇原创文章 · 获赞 7 · 访问量 818

猜你喜欢

转载自blog.csdn.net/Young_Naive/article/details/104028310