7-33 删除字符串中的子串 (20 分)

输入2个字符串S1和S2,要求删除字符串S1中出现的所有子串S2,即结果字符串中不能包含S2。

输入格式:
输入在2行中分别给出不超过80个字符长度的、以回车结束的2个非空字符串,对应S1和S2。

输出格式:
在一行中输出删除字符串S1中出现的所有子串S2后的结果字符串。

输入样例:
Tomcat is a male ccatat
cat
输出样例:
Tom is a male

#include<stdio.h>
#include <string.h>
int main(void)
{
	char a[81],b[81],c[81]={0},*p;
	gets(a);
	gets(b);
	while((p=strstr(a,b))!='\0'){
		*p='\0';
		strcat(c, a);
		strcat(c, p + strlen(b));
		strcpy(a, c);
		c[0] = '\0';	
	}
	printf("%s",a);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Guooooozy/article/details/84934097
今日推荐