A-Lovers【暑假训练赛2】

Description

One day n girls and n boys come to Xi’an to look for a mate. Each girl has a value a[i], each boy has a value b[i]. Girl i and boy j will fall in love only if a[i] + b[j] ≥ k.
Please help them make pairs as many as possible.

Input

Several test cases .
First line an integer T (1 ≤ T ≤ 10). Indicates the number of test cases.
Then T test cases follows. Each test case begins with two integer N, K (1 ≤ N ≤ 200000,0 ≤ K ≤ 109). The next line has N integers indicate a[1] to a[N] (0 ≤ a[i] ≤ 10^9). The next line has N integers indicate b[1] to b[N] (0 ≤ b[i] ≤ 10^9)

Output

For each test case, print the answer in a single line.

Sample Input

1
3 4
1 2 3
1 2 3

Sample Output

3

Code

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn=200000+10;
int a[maxn];
int b[maxn];

int main(){
    int t;
    cin>>t;
    while(t--){
        int n,k;
        cin>>n>>k;
        for(int i=0;i<n;i++){
            scanf("%d",&a[i]);
            getchar();
        }
        for(int i=0;i<n;i++){
            scanf("%d",&b[i]);
            getchar();
        }
        sort(a,a+n);  
        sort(b,b+n);  
        if(a[n-1]+b[n-1]<k){
            printf("0\n");
            continue;
        }
		int j=0,num=0;
        for(int i=n-1;i>=0;i--){
            for(;j<n;j++){
                if(a[j]+b[i]==k){
                    num++;
					j=j+1;
					break;
                }
            }
        }
        printf("%d\n",num);
    }
    return 0;
}
发布了25 篇原创文章 · 获赞 5 · 访问量 1682

猜你喜欢

转载自blog.csdn.net/qq_43611144/article/details/98850152