C-Rabbits【思维题·暑假训练赛1】

Description

Here N (N ≥ 3) rabbits are playing by the river. They are playing on a number line, each occupying a different integer. In a single move, one of the outer rabbits jumps into a space between any other two. At no point may two rabbits occupy the same position.
Help them play as long as possible.

Input

The input has several test cases. The first line of input contains an integer t (1 ≤ t ≤ 500) indicating the number of test cases.
For each case the first line contains the integer N (3 ≤ N ≤ 500) described as above. The second line contains n integers a1 < a2 < a3 < · · · < aN which are the initial positions of the rabbits.
For each rabbit, its initial position ai satisfies 1 ≤ ai ≤ 10000.

Output

For each case, output the largest number of moves the rabbits can make.

Sample Input

5
3
3 4 6
3
2 3 5
3
3 5 9
4
1 2 3 4
4
1 2 4 5

Sample Output

1
1
3
0
1

Code

/*
题意:站在line中最左端和最右端的兔子向line中跳入任意两只中间存在空位的兔子的空位中,
*/
#include <iostream>
#include <cstdio>
using namespace std;
int num[510];

int main(){
    int t;
    cin>>t;
    while(t--){
       int n;
       cin>>n;
       for(int i=0;i<n;i++){
          scanf("%d",&num[i]);
          getchar();
       }
       int sum=0;
       for(int i=0;i<n-1;i++){
          sum=sum+num[i+1]-num[i]-1;
       }
       //舍去最左端、最右端中较小的一个
       if((num[1]-num[0])>(num[n-1]-num[n-2])) sum=sum-(num[n-1]-num[n-2]-1);
       else sum=sum-(num[1]-num[0]-1);
       printf("%d\n",sum);
    }
    return 0;
}

发布了25 篇原创文章 · 获赞 5 · 访问量 1679

猜你喜欢

转载自blog.csdn.net/qq_43611144/article/details/98980480
今日推荐