【PTA】7-38 关于堆的判断

题目重述

将一系列给定数字顺序插入一个初始为空的小顶堆H[]。随后判断一系列相关命题是否为真。命题分下列几种:

  • x is the root:x是根结点;
  • x and y are siblings:x和y是兄弟结点;
  • x is the parent of y:x是y的父结点;
  • x is a child of y:x是y的一个子结点。

输入格式:

每组测试第1行包含2个正整数N(≤ 1000)和M(≤ 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间[−10000,10000]内的N个要被插入一个初始为空的小顶堆的整数。之后M行,每行给出一个命题。题目保证命题中的结点键值都是存在的。

输出格式:

对输入的每个命题,如果其为真,则在一行中输出T,否则输出F。

输入样例:

5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10

输出样例:

F
T
F
T

题解

构造最小堆,然后判断即可,因为我是从下标1开始输出的 所以i的父亲下标就是i/2。

C++ AC

#include <iostream>
#include <bits/stdc++.h>
using namespace std;
int heap[1005];
int n,m,x,y;
int find_loc(int value)
{
    for(int i=1;i<=n;i++)
    {
        if(value==heap[i])
        {
            return i;
        }
    }
    return -1;
}
int main()
{
    string tmp="";
    cin>>n>>m;
    for(int i=1;i<=n;i++)
    {
        cin>>heap[i];
        int t=i;
		while(t>1&&heap[t]<heap[t/2])
		{
			swap(heap[t],heap[t/2]);
			t/=2;
		}
    }
    for(int i=0;i<m;i++)
    {
        cin>>x;
        cin>>tmp;
        if(tmp=="is")
        {
            cin>>tmp;
            if(tmp=="the")
            {
                cin>>tmp;
                if(tmp=="root")
                {
                    cout<<((x==heap[1])? "T":"F")<<endl;
                }
                else
                {
                    cin>>tmp;
                    cin>>y;
                    cout<<((find_loc(x)==find_loc(y)/2)? "T":"F")<<endl;
                }
            }
            else
            {
                cin>>tmp;
                cin>>tmp;
                cin>>y;
                 //cout<<x<<":"<<y<<endl;
                 cout<<((find_loc(y)==find_loc(x)/2)? "T":"F")<<endl;
            }
        }
        else
        {
            cin>>y;
            cin.ignore();
            getline(cin,tmp);

            int lox=(find_loc(x))/2;
            int loy=(find_loc(y))/2;
            cout<<(lox==loy? "T":"F")<<endl;
        }
    }
    return 0;
}

发布了243 篇原创文章 · 获赞 106 · 访问量 5万+

猜你喜欢

转载自blog.csdn.net/weixin_43889841/article/details/104156856