Shuffle Card

Problem Description
A deck of card consists of n cards. Each card is different, numbered from 1 to n. At first, the cards were ordered from 1 to n. We complete the shuffle process in the following way, In each operation, we will draw a card and put it in the position of the first card, and repeat this operation for m times.

Please output the order of cards after m operations

Input
The first line of input contains two positive integers n and m.(1<=n,m<=105)

The second line of the input file has n Numbers, a sequence of 1 through n.

Next there are m rows, each of which has a positive integer si, representing the card number extracted by the i-th operation.

Output
Please output the order of cards after m operations. (There should be one space after each number.)

Sample Input

5 3
1 2 3 4 5
3
4
3

Sample Output

3 4 1 2 5

题意描述:
给出n个数是1到n然后再给出m个数,每一个数代表一种操作,就是把这个数放在队首,然后在输出,这m中操作结束后的数组中元素的顺序。

#include<string.h>
#include<stdio.h>

int book[100100],s[300100];
int main()
{
    int m,n;
    scanf("%d%d",&m,&n);
    int i,j,k,a,b;
    for(i=1;i<=m;i++)
        book[i]=0;
    for(i=100100;i<100100+m;i++)
        scanf("%d",&s[i]);
    for(i=100099;i>100099-n;i--)
        scanf("%d",&s[i]);
    printf("%d ",s[100100-n]);
    book[s[100100-n]]=1;
    for(i=100100-n+1;i<100100+m;i++)
    {
        if(book[s[i]]==0)
        {
            printf("%d ",s[i]);
            book[s[i]]=1;
        }
    }
    return 0;
}
发布了53 篇原创文章 · 获赞 1 · 访问量 1347

猜你喜欢

转载自blog.csdn.net/fgets__/article/details/100040923