HDU6205 card card card

Problem Description
As a fan of Doudizhu, WYJ likes collecting playing cards very much.
One day, MJF takes a stack of cards and talks to him: let’s play a game and if you win, you can get all these cards. MJF randomly assigns these cards into n heaps, arranges in a row, and sets a value on each heap, which is called “penalty value”.
Before the game starts, WYJ can move the foremost heap to the end any times.
After that, WYJ takes the heap of cards one by one, each time he needs to move all cards of the current heap to his hands and face them up, then he turns over some cards and the number of cards he turned is equal to the penaltyvalue.
If at one moment, the number of cards he holds which are face-up is less than the penaltyvalue, then the game ends. And WYJ can get all the cards in his hands (both face-up and face-down).
Your task is to help WYJ maximize the number of cards he can get in the end. So he needs to decide how many heaps that he should move to the end before the game starts. Can you help him find the answer?
MJF also guarantees that the sum of all “penalty value” is exactly equal to the number of all cards.

Input
There are about 10 test cases ending up with EOF.
For each test case:
the first line is an integer n ( 1n106 ), denoting n heaps of cards;
next line contains n integers, the i th integer ai ( 0ai1000 ) denoting there are ai cards in i th heap;
then the third line also contains n integers, the i th integer bi ( 1bi1000 ) denoting the “penalty value” of i th heap is bi .

Output
For each test case, print only an integer, denoting the number of piles WYJ needs to move before the game starts. If there are multiple solutions, print the smallest one.

Sample Input
5
4 6 2 8 4
1 5 7 9 2

Sample Output
4

Hint
For the sample input:

  • If WYJ doesn’t move the cards pile, when the game starts the state of cards is:
    4 6 2 8 4
    1 5 7 9 2

WYJ can take the first three piles of cards, and during the process, the number of face-up cards is 4-1+6-5+2-7. Then he can’t pay the the “penalty value” of the third pile, the game ends. WYJ will get 12 cards.
+ If WYJ move the first four piles of cards to the end, when the game starts the state of cards is:

    4 4 6 2 8
    2 1 5 7 9

WYJ can take all the five piles of cards, and during the process, the number of face-up cards is 4-2+4-1+6-5+2-7+8-9. Then he takes all cards, the game ends. WYJ will get 24 cards.

It can be improved that the answer is 4.

huge input, please use fastIO.

Source
2017 ACM/ICPC Asia Regional Shenyang Online


结论:对每一堆牌的「盈亏」做 O(n) 的最大连续子序列和。
虽然当时得出了这个结论但是仍然WA……大概是哪个地方脑子短路了没有写好罢。

#include<stdio.h>
#include<string.h>

typedef unsigned long long ll;

int K;
// 为了方便操作将盈亏“重复一遍”
int N[2000010];

int main(){
    while(~scanf("%d",&K)){
        int sum, resleft, resright;
        for(int i=0;i<K;i++){scanf("%d",&N[i]); N[i+K]=N[i]; }
        for(int i=0;i<K;i++){int a; scanf("%d",&a); N[i]-=a; N[i+K]-=a; }
        int left=0,right=1;
        // 跳过开头盈亏为负值的部分
        while(N[left]<0&&left<2*K){left++;right++;}
        int localsum=N[left], sumleft=left;
        int localcurrent=N[left], currentleft=left;
        for(int i=left+1;i<2*K;i++){
            if(localcurrent<0){
                localcurrent = N[i];
                currentleft = i;
            } else {
                localcurrent += N[i];
            }
            if(localsum < localcurrent){
                localsum = localcurrent;
                sumleft = currentleft;
            }
        }
        resleft = sumleft;
        printf("%d\n",resleft);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/erikabeats/article/details/78138500