PAT 甲级 A1022

1022 Digital Library (30分)

题目描述

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID’s.

输入格式

Each input file contains one test case. For each case, the first line contains a positive integer N (≤ 10 4 10​^{4} ) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

  • Line #1: the 7-digit ID number;
  • Line #2: the book title – a string of no more than 80 characters;
  • Line #3: the author – a string of no more than 80 characters;
  • Line #4: the key words – each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
  • Line #5: the publisher – a string of no more than 80 characters;
  • Line #6: the published year – a 4-digit number which is in the range [1000, 3000].
    It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M (≤1000) which is the number of user’s search queries. Then M lines follow, each in one of the formats shown below:

  • 1: a book title
  • 2: name of an author
  • 3: a key word
  • 4: name of a publisher
  • 5: a 4-digit number representing the year

输出格式

For each query, first print the original query in a line, then output the resulting book ID’s in increasing order, each occupying a line. If no book is found, print Not Found instead.

Sample Input:

3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla

Sample Output:

1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found

总结

  1. 设置一个数组,用一个unordered_map<string, set<int>> information[5]进行存储就好了,因为id有可能重复的,且要求递增,set<int>完美实现了这个要求。下标对应不同类型的查询,比如进行1类型的查询就对应下标0。此外,关键词对应的查询,要特殊处理。
  2. 注意处理换行符和空格
  3. 注意id必须以7位的输出,PAT很多题都是这个套路。测试点4,5就包括前导为0的id,如0001111,转化为int会变为1111。

AC代码

#include <iostream>
#include<string>
#include<unordered_map>
#include<set>
using namespace std;
int main() {
	int n, id, index;
	string temp, query;
	unordered_map<string, set<int>> information[5];
	scanf("%d", &n);
	while (n--) {
		scanf("%d", &id);
		getchar();
		for (int i = 0; i < 5; i++) {
			if (i != 2) {
				getline(cin, temp);
				information[i][temp].insert(id);
			}
			else {  //关键词一栏
				while (cin >> temp) {
					information[i][temp].insert(id);
					if (getchar() == '\n') break;
				}
			}
		}
	}
	scanf("%d", &n);
	while (n--) {
		scanf("%d: ", &index);
		getline(cin, query);
		cout << index << ": " << query << endl;
		if (information[index-1].find(query) == information[index-1].end()) {
			printf("Not Found\n");
		}
		else {
			for (set<int>::iterator i = information[index-1][query].begin(); i != information[index-1][query].end(); i++)
				printf("%07d\n", *i);  //不设置7位会在测试点4和5过不去
		}
	}
	return 0;
}
发布了16 篇原创文章 · 获赞 0 · 访问量 359

猜你喜欢

转载自blog.csdn.net/qq_38507937/article/details/104296448
今日推荐