PAT甲级-1022-Digital Library(map映射+倒排索引+set)

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID’s.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤104) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:.

  • Line #1: the 7-digit ID number;
  • Line #2: the book title – a string of no more than 80 characters;
  • Line #3: the author – a string of no more than 80 characters;
  • Line #4: the key words – each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
  • Line #5: the publisher – a string of no more than 80 characters;
  • Line #6: the published year – a 4-digit number which is in the range [1000, 3000].

It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M (≤1000) which is the number of user’s search queries. Then M lines follow, each in one of the formats shown below:

  • 1: a book title
  • 2: name of an author
  • 3: a key word
  • 4: name of a publisher
  • 5: a 4-digit number representing the year
Output Specification:

For each query, first print the original query in a line, then output the resulting book ID’s in increasing order, each occupying a line. If no book is found, print Not Found instead.

Sample Input :
3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla

Sample Output :
1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found

思路:

本题非常类似于搜索引擎,根据输入的关键词(书本的5条信息:a book title,name of an author,a key word,name of a publisher,a 4-digit number representing the year)搜索出一篇或数篇包含该关键词的文档(book IDs),所以要采用倒排索引的思想,对书本的5条信息分别建立语料库,里面存放其对应的书的id集合

  • 注意:要加上&,否则会超时!

代码如下

#include<iostream>
#include<map>
#include<set>
using namespace std;
map<string, set<int> >title,author,key,pub,year;
void search(map<string, set<int> > &m, string &s){
	if(m.find(s) != m.end()){
		set<int>::iterator it;
		for(it=m[s].begin();it!=m[s].end();it++)
			printf("%07d\n", int(*it));
	}else{
		cout<<"Not Found\n";
	}
}
int main()
{
	int n,m,id,ch;
	string ti,au,ke,pu,ye;
	scanf("%d", &n);
	for(int i = 0; i < n; i++){
		scanf("%d\n", &id);
		//cout<<id<<endl;
		getline(cin, ti);
		//cout<<ti<<endl;
		title[ti].insert(id);
		getline(cin, au);
		author[au].insert(id);
		while(cin >> ke){
			key[ke].insert(id);
			char c = getchar();
			if(c == '\n') break;
		}
		getline(cin, pu);
		pub[pu].insert(id);
		getline(cin, ye);
		year[ye].insert(id);
	}
	scanf("%d", &m);
	for(int i = 0; i < m; i++){
		scanf("%d: ", &ch);
		string tmp;getline(cin, tmp);
		cout<<ch<<": "<<tmp<<endl;
		if(ch == 1) search(title, tmp);
		else if(ch == 2) search(author, tmp);
		else if(ch == 3) search(key, tmp);
		else if(ch == 4) search(pub, tmp);
		else if(ch == 5) search(year, tmp);
	}
	
	return 0;
}
发布了110 篇原创文章 · 获赞 746 · 访问量 3万+

猜你喜欢

转载自blog.csdn.net/qq_42437577/article/details/104157286