【PAT】A1022 Digital Library (30point(s))


Author: CHEN, Yue
Organization: 浙江大学
Time Limit: 1200 ms
Memory Limit: 64 MB
Code Size Limit: 16 KB

A1022 Digital Library (30point(s))

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID’s.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤10​^4​​ ) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

Line #1: the 7-digit ID number;
Line #2: the book title – a string of no more than 80 characters;
Line #3: the author – a string of no more than 80 characters;
Line #4: the key words – each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
Line #5: the publisher – a string of no more than 80 characters;
Line #6: the published year – a 4-digit number which is in the range [1000, 3000].
It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M (≤1000) which is the number of user’s search queries. Then M lines follow, each in one of the formats shown below:

1: a book title
2: name of an author
3: a key word
4: name of a publisher
5: a 4-digit number representing the year

Output Specification:

For each query, first print the original query in a line, then output the resulting book ID’s in increasing order, each occupying a line. If no book is found, print Not Found instead.

Sample Input:

3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla

Sample Output:

1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found

Code(柳神的代码

#include <iostream>
#include <stdio.h>
#include <map>
#include <set>
using namespace std;
map<string, set<int>> mtitle, mauthor, mkey, mpublisher, myear;		// 给每一种信息设置一个map,映射ID
void print(map<string, set<int>> &a, string str){		// 注意用引用,不然最后一个点会超时
	if (a.find(str) != a.end()){
	  for (set<int>::iterator it = a[str].begin(); it != a[str].end(); it++)
			printf("%07d\n", *it);
	}
	else	printf("Not Found\n");
}
int main(){
	int n, m, id;
	scanf("%d", &n);
	string title, author, key, publisher, year, t;
	for (int i = 0; i < n; i++){
		scanf("%d\n", &id);				// 注意:需要把回车符也接收了
		getline(cin, title);
		mtitle[title].insert(id);
		getline(cin, author);
		mauthor[author].insert(id);
		while (cin >> key){				// 关键词可能有多个
			mkey[key].insert(id);
			char c = getchar();			// 接收空格并且可用于判断关键词是否接收完
			if (c == '\n')	break;		// 看到回车符说明关键词接收完毕
		}
		getline(cin, publisher);
		mpublisher[publisher].insert(id);
		getline(cin, year);
		myear[year].insert(id);
	}
	scanf("%d", &m);
	for (int i = 0; i < m; i++){
		scanf("%d: ", &n);
		getline(cin, t);
		printf("%d: %s\n", n, t.c_str());
		switch (n){
		case 1:print(mtitle, t); break;
		case 2:print(mauthor, t); break;
		case 3:print(mkey, t); break;
		case 4:print(mpublisher, t); break;
		case 5:print(myear, t); break;
		default: break;
		}
	}
	return 0;
}

Analysis

-已知有n本书,以及书的7位ID、不超过80字的书名、不超过80字的作者名、不超过10字之间无空格的关键字(两个关键字之间才有空格)、不超过80字的出版社名、1000至3000的4位年份。共6种信息。

-给出m个查询,每个查询前有一个数字(1-6),表示查询时输入的数据什么类型(对应上面6种信息)。对于每一个查询,输出符合查询要求的书的7位ID。如果没有符合要求的书,则输出Not Found。

-注意使用getline()来接受数据!查看样例就可以知道,书名、作者名等之间都有空格!

-注意print()函数参数要用引用,不然最后一个点会超时。

发布了159 篇原创文章 · 获赞 17 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/ztmajor/article/details/103790742