CF1288C-Two Arrays-思维+dp

Description

You are given two integers n and m. Calculate the number of pairs of arrays (a,b) such that:

  • the length of both arrays is equal to m;
  • each element of each array is an integer between 1 and n (inclusive);
  • ai≤bi for any index i from 1 to m;
  • array a is sorted in non-descending order;
  • array b is sorted in non-ascending order.

As the result can be very large, you should print it modulo 109+7.

Input

The only line contains two integers n and m (1≤n≤1000, 1≤m≤10).

Output

Print one integer – the number of arrays a and b satisfying the conditions described above modulo 109+7.

Sample Input

723 9

Sample Output

157557417

核心思想:

1、序列a非递减,即am是a中最大的数
2、序列b非递增,即bm是b中最小的数
3、由ai≤bi可得am≤bm
有上述三点可以推出:
先顺序遍历序列a,再逆序遍历序列b,可以得到一个长度为2*m的非递减序列c。(即将序列a和b的尾部相连)

至此,题目转换为求满足以下条件的序列c的个数:
1、长度为2*m
2、ci的取值范围为[1,n]
3、序列c非递减

dp解决此问题:
dp[i][j]表示满足以下条件的序列个数:
1、长度为i
2、第一个数为j
3、序列非递减

详见代码!

代码如下:

#include<cstdio>
#include<iostream>
using namespace std;
typedef long long ll;
const int N=1100,M=11;
const ll mo=1e9+7;
ll dp[M<<1][N];
int main()
{
	int n,m;
	cin>>n>>m;
	m<<=1;
	for(int i=1;i<=n;i++)
		dp[1][i]=1;
	for(int i=2;i<=m;i++)
		for(int j=n;j>0;j--)
			dp[i][j]=(dp[i][j+1]+dp[i-1][j])%mo;
	ll ans=0;
	for(int i=1;i<=n;i++)
		ans=(ans+dp[m][i])%mo;
	cout<<ans<<endl;
	return 0;
}
发布了144 篇原创文章 · 获赞 135 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/Nothing_but_Fight/article/details/103983854