PAT甲级-1050-String Subtraction(hash散列)

Given two strings S1 and S2, S = S1 – S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1 – S2 for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 104. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S1 – S2 in one line.

Sample Input:
They are students.
aeiou
Sample Output:
Thy r stdnts.

思路:

int flag[10000]一维数组标记字符在s2中的出现情况,flag[i]=1表示字符在s2中出现过,遇到flag[i]=1在s1中不打印该字符即可。

代码如下

#include<iostream>
using namespace std;
int flag[10000];
int main()
{
	string s1,s2;
	getline(cin, s1);
	getline(cin, s2);
	for(int i = 0; i < s2.length(); i++){
		flag[s2[i]] = 1;
	}
	for(int i = 0; i < s1.length(); i++){
		if(!flag[s1[i]]){
			printf("%c", s1[i]);
		}
	}
	return  0;
}
发布了110 篇原创文章 · 获赞 746 · 访问量 3万+

猜你喜欢

转载自blog.csdn.net/qq_42437577/article/details/104199700