HDOJ1051木棒问题(贪心算法)

HDOJ1051木棒问题(贪心算法)

题意:机器重启一次要1分钟 ,下一根木棒比上一根木棒长且重就可以通过,不然机器要重启

思路:1.为木棒定义结构体记录长、重,自定义函数comp将木棒按照长度由小到大排列,长度一样就按照重量比较

2.两个for循环筛掉下一根木棒比上一根木棒轻的(重的就通过了,不重启,标记此木棒-1,代表已经用过),并且用sum标记重启次数

Problem Description

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l’ and weight w’ if l<=l’ and w<=w’. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, …, ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

Output

The output should contain the minimum setup time in minutes, one per line.

Sample Input

3 
5 
4 9 5 2 2 1 3 5 1 4 
3 
2 2 1 1 2 2 
3 
1 3 2 2 3 1

Sample Output

2
1
3

代码思路:1.为木棒定义结构体记录长、重,自定义函数comp将木棒按照长度由小到大排列,长度一样就按照重量比较
2.两个for循环筛掉下一根木棒比上一根木棒轻的(重的就通过了,不重启,标记此木棒-1,代表已经用过),并且用sum标记重启次数

#include <iostream>
#include <vector>
#include <algorithm>
#include <math.h>
using namespace std;
/* run this program using the console pauser or add your own getch, system("pause") or input loop */
struct wo {
	int l;
	int w;
};
bool comp(wo a,wo b ) {      //将木棒排序,排序按照l从大到小。若l一致,就比较w 
	if(a.l!=b.l) return a.l<b.l;
	else return a.w<b.w;
}

int main(int argc, char** argv) {
	int t,n,l,w;
	wo wood[5005];
	cin>>t;
	getchar();
	while(t--) {
		cin>>n;
		getchar();
		int i=0;
		for(int i=0;i<n;i++){
			cin>>wood[i].l>>wood[i].w;
		}
		sort(wood,wood+n,comp);    //按照cmp的方式排序 
		int min,sum=0;
		
		for(int j=0;j<n;j++){
			if(wood[j].w!=-1){    	//wood[i].w==-1代表此条木棒已经用过了 
				min=wood[j].w;
				sum++;
				for(int k=j+1;k<n;k++){
					if(wood[k].w>=min&&wood[k].w!=-1){
						min=wood[k].w;
						wood[k].w=-1;
					}
				}
			}
		}
		
		cout<<sum<<endl;

	}

	return 0;
}
发布了4 篇原创文章 · 获赞 0 · 访问量 82

猜你喜欢

转载自blog.csdn.net/qq_39814753/article/details/104278014