问题 J: Lamp---------------思维/前缀和

题目描述
There is a grid with H horizontal rows and W vertical columns, and there are obstacles on some of the squares.

Snuke is going to choose one of the squares not occupied by an obstacle and place a lamp on it. The lamp placed on the square will emit straight beams of light in four cardinal directions: up, down, left, and right. In each direction, the beam will continue traveling until it hits a square occupied by an obstacle or it hits the border of the grid. It will light all the squares on the way, including the square on which the lamp is placed, but not the square occupied by an obstacle.

Snuke wants to maximize the number of squares lighted by the lamp.

You are given H strings Si (1≤i≤H), each of length W. If the j-th character (1≤j≤W) of Si is #, there is an obstacle on the square at the i-th row from the top and the j-th column from the left; if that character is ., there is no obstacle on that square.

Find the maximum possible number of squares lighted by the lamp.

Constraints
·1≤H≤2,000
·1≤W≤2,000
·Si is a string of length W consisting of # and ‘.’.
·’.’ occurs at least once in one of the strings Si (1≤i≤H).
输入
Input is given from Standard Input in the following format:

H W
S1
:
SH

输出
Print the maximum possible number of squares lighted by the lamp.
样例输入 Copy
【样例1】
4 6
#…#…
…#
…#.
#.#…
【样例2】
8 8
…#…#.
…#…
##…
…###…#
…#…#.
##…#.
#…#…
###.#…#
样例输出 Copy
【样例1】

8
【样例2】
13

题意:
现在要安装一个灯,这个灯的光束可以把上下左右都给照亮。请问最大能照亮多少块。
解析:
维护上下左右连续点的前缀和
当查询某个点的时候。维护的这四个方向的数组都加起来。再减去3,因为重复累加了4次。


#include<bits/stdc++.h>
using namespace std;
const int N=2005;
int l[N][N],r[N][N],up[N][N],down[N][N];
char s[N][N];
int n,m;
int main()
{
	cin>>n>>m;
	for(int i=1;i<=n;i++) cin>>(s[i]+1);
	for(int j=1;j<=m;j++)
	{
		for(int i=1;i<=n;i++) 
			if(s[i][j]=='.') up[i][j]=up[i-1][j]+1;
			else up[i][j]=0;
		for(int i=n;i>=1;i--) 
			if(s[i][j]=='.') down[i][j]=down[i+1][j]+1;
			else down[i][j]=0;
	}
	for(int i=1;i<=n;i++)
	{
		for(int j=1;j<=m;j++) 
			if(s[i][j]=='.') l[i][j]=l[i][j-1]+1;
			else l[i][j]=0;
		for(int j=m;j>=1;j--) 
			if(s[i][j]=='.')r[i][j]=r[i][j+1]+1;
			else r[i][j]=0;
	}
	int ans=-1;
	for(int i=1;i<=n;i++)
		for(int j=1;j<=m;j++)
		{
			if(s[i][j]=='.')
			{
				ans=max(ans,l[i][j]+r[i][j]+up[i][j]+down[i][j]-3);
			}
		}
	cout<<ans<<endl;
 } 
发布了384 篇原创文章 · 获赞 7 · 访问量 8070

猜你喜欢

转载自blog.csdn.net/qq_43690454/article/details/104147202