PAT (Advanced Level) Practice 1044 Shopping in Mars(25分)【双指针】

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

  1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
  2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
  3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N ( 1 0 5 ) N (≤10^5) , the total number of diamonds on the chain, and M ( 1 0 8 ) M (≤10^8) , the amount that the customer has to pay. Then the next line contains N N positive numbers D 1 D N ( D i 1 0 3 D_1⋯D_N(D_i≤10^3 for all i = 1 , , N ) i=1,⋯,N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print i-j in a line for each pair of i j i ≤ j such that D i + . . . + D j = M D_i + ... + D_j = M . Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output i-j for pairs of i j i ≤ j such that D i + . . . + D j > M D_i + ... + D_j >M with ( D i + . . . + D j M ) (D_i + ... + D_j −M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

Sample Output 1:

1-5
4-6
7-8
11-11

Sample Input 2:

5 13
2 4 5 7 9

Sample Output 2:

2-4
4-5

题意

找出所有的数字串,使其和为一个确定的值,如果没有则要求在和大于这个值的情况下尽可能接近。

思路

基本想法是遍历所有可能的子串,通过剪枝使时间复杂度降到 O ( n ) O(n) 。在左边界固定的情况下,通过不断右移右边界,就可以考察一组子串。一旦发现了一个有可能成为答案的子串(和大于M),右边界再右移一定不是答案(因为和更大)。这时就应该将左边界右移,考察下一组子串。

代码

#include <cstdio>

using namespace std;

int d[100005];
int ans[100005][2];

int main() {
    int n, m;

    scanf("%d %d\n", &n, &m);
    for (int i = 0; i < n; ++i)
        scanf("%d", d + i);

    int sum = 0, leftPos = 0, cnt = 0, cost = 100000005;
    for (int i = 0; i < n; ++i) {
        sum += d[i];
        while (sum >= m && leftPos <= i) {
            if (cost > sum - m) {
                cost = sum - m;
                cnt = 0;
            }
            if (cost == sum - m) {
                ans[cnt][0] = leftPos + 1;
                ans[cnt][1] = i + 1;
                ++cnt;
            }
            sum -= d[leftPos++];
        }
    }

    for (int i = 0; i < cnt; ++i)
        printf("%d-%d\n", ans[i][0], ans[i][1]);
}
发布了184 篇原创文章 · 获赞 19 · 访问量 2万+

猜你喜欢

转载自blog.csdn.net/Exupery_/article/details/103781733