PAT A 1044 Shopping in Mars

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

  1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).\

    Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).\
    Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).\

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=10^5^), the total number of diamonds on the chain, and M (<=10^8^), the amount that the customer has to pay. Then the next line contains N positive numbers D~1~ … D~N~ (D~i~<=10^3^ for all i=1, …, N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print “i-j” in a line for each pair of i <= j such that D~i~ + … + D~j~ = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output “i-j” for pairs of i <= j such that D~i~ + … + D~j~ > M with (D~i~ + … + D~j~ - M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

Sample Output 1:

1-5
4-6
7-8
11-11

Sample Input 2:

5 13
2 4 5 7 9

Sample Output 2:

2-4
4-5

总体思路,参考算法笔记。但我写的不同的是,找第一个大于等于的位置。

#include<cstdio>

const int maxn = 100001000;
int sum[maxn] = { 0 };

int lower_bound(int left,int right,int x) {
    int mid;
    while (left < right) {
        mid = (left + right) / 2;
        if (sum[mid]>=x) right = mid;
        else left = mid + 1;
    }
    return left;
}

int main() {
    int M, N;
    int min = 1000;
    scanf("%d %d", &N, &M);
    for (int i = 1; i <= N; i++) {
        scanf("%d", &sum[i]);
        sum[i] = sum[i] + sum[i - 1];
    }
    for (int i = 1; i <= N; i++) {
        int j = lower_bound(i, N ,sum[i-1]+ M);
        if (sum[j] - sum[i - 1] == M) {
            min = M;
            break;
        }
        else if (sum[j] - sum[i - 1] < min && sum[j] - sum[i - 1]>M)//唯一的坑点在这里,后面要再加一个判断条件,否则当i=N时,就一个数,可能就恰好比min小,改变了min的值,但这不是符合条件的。就比如sample2.
            min = sum[j] - sum[i - 1];
    }

    for (int i = 1; i <= N; i++) {
        int j = lower_bound(i, N , sum[i-1]+min);
        if(sum[j]-sum[i-1]==min) printf("%d-%d\n", i, j);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/joah_ge/article/details/81042185
今日推荐