BZOJ 1623: [Usaco2008 Open]Cow Cars 奶牛飞车【二分+贪心】

1623: [Usaco2008 Open]Cow Cars 奶牛飞车

Time Limit: 5 Sec Memory Limit: 64 MB

Description

编号为1到N的N只奶牛正各自驾着车打算在牛德比亚的高速公路上飞驰.高速公路有M(1≤M≤N)条车道.奶牛i有一个自己的车速上限Si(l≤Si≤1,000,000).
在经历过糟糕的驾驶事故之后,奶牛们变得十分小心,避免碰撞的发生.每条车道上,如果某一只奶牛i的前面有K只奶牛驾车行驶,那奶牛i的速度上限就会下降K*D个单位,也就是说,她的速度不会超过Si - kD(O≤D≤5000),当然如果这个数是负的,那她的速度将是0.牛德比亚的高速会路法规定,在高速公路上行驶的车辆时速不得低于/(1≤L≤1,000,000).那么,请你计算有多少奶牛可以在高速公路上行驶呢?

Input

第1行输入N,M,D,L四个整数,之后N行每行一个整数输入Si.
N<=50000

Output

输出最多有多少奶牛可以在高速公路上行驶.
Sample Input

3 1 1 5//三头牛开车过一个通道.当一个牛进入通道时,它的速度V会变成V-D*X(X代表在它前面有多少牛),它减速后,速度不能小于L
5
7
5
INPUT DETAILS:
There are three cows with one lane to drive on, a speed decrease
of 1, and a minimum speed limit of 5.

Sample Output

2
OUTPUT DETAILS:
Two cows are possible, by putting either cow with speed 5 first and the cow
with speed 7 second.

题解

我们有个贪心的想法,让越大的越后放,但是我们不知道哪些作为第一个,那么二分一下就可以了。

代码如下

#include<cstdio>
#include<algorithm>
using namespace std;
int n,m,D,L,a[50005],Ans;
bool check(int i){
    int Now=0,cnt=0;
    for(;i<=n;i++)
    if(a[i]-D*Now>=L){
        cnt++;
        if(cnt==m) cnt=0,Now++;
    }else return 0;
    return 1;
}
int main(){
    #ifndef ONLINE_JUDGE
    freopen("prob.in","r",stdin);
    freopen("prob.out","w",stdout);
    #endif
    scanf("%d%d%d%d",&n,&m,&D,&L);
    for(int i=1;i<=n;i++) scanf("%d",&a[i]);
    sort(a+1,a+1+n);
    for(int L=0,R=n,mid=(R+L)>>1;L<=R;mid=(R+L)>>1)
    if(check(mid)) Ans=mid,R=mid-1;else L=mid+1;
    printf("%d\n",n-Ans+1);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41357771/article/details/80328659